Announcement

Collapse
No announcement yet.

Had to restore database from backup... what next

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Had to restore database from backup... what next

    I had to restore my db and as it wouldn't allow me to restore it the first time... I deleted it and then rebuilt it with the same name, username, and passwords. Now, nothing is showing at the hompage level but I can access the admincp but its really messed up. (see attachement)

    Can anyone help me out from here? What do I need to do?
    Attached Files

  • #2
    It looks like the export wasn't 100% complete.

    http://www.vBulletin.com/go/backup

    http://www.vBulletin.com/go/restore

    Make another backup, make sure it's 100% - I recommend using SSH (Shell)

    Import it to a new database, and update config.php to point to it.

    Make sure you use the same files as from the backup. if you run 3.6.1 on the old one use 3.6.1 again ..

    Comment


    • #3
      This is the only backup I have as the site was hacked last night and this is why I am trying to repair it. The backup is 4 days old there haven't been any changes since.

      Comment


      • #4
        In the .sql dump, what are the last 3 lines?

        Comment


        • #5
          What you can do is upload tools.php into the admincp directory and run it. re-import the style, the language and the other .xml files. And then rebuild the caches and reset the cookie path and domain.

          tools.php is in the do_not_upload/ folder from the vbulletin's zip file.

          When done using tools.php, remove it from the server


          Once your site runs again, make sure you upgrade it to 3.6.8 PL2


          Sticky: How To Make My Forums More Secure

          Comment


          • #6
            Originally posted by Floris View Post
            In the .sql dump, what are the last 3 lines?


            ('99927', 'P', 'Point Baker', 'D', 'Alaska', 'AK', 907, '56.24671', '133.3565'),
            ('99928', 'P', 'Ward Cove', 'D', 'Alaska', 'AK', 907, '55.45570', '131.7925'),
            ('99929', 'P', 'Wrangell', 'D', 'Alaska', 'AK', 907, '56.46768', '132.3845');

            Comment


            • #7
              Hm, .. I was hoping it would be a complete line, like


              INSERT vb_word (..);

              Could you PrivMsg me an URL or ftp where I can download the .sql dump so I can take a look?

              Comment


              • #8
                The backup is complete, I see it all the way up to 'word' table. It seems to be in order.

                Did you try the tools.php tip I gave?

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X