Announcement

Collapse
No announcement yet.

vBulletin Moved - Signatures Lost / Members Renumbered

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    You will also need to update the relevant userid in every other table that has a userid field.

    Leave a comment:


  • dbenton
    replied
    We have contact Houston!!

    OK, we got it!! I am posting this just in case anyone else has had this problem and is looking for a solution. It is not the easiest one in the world, but it does work. In the event that you have 2 user id's per person and the board is only showing results and signatures on the new post with the new id, you will need to run this script.

    UPDATE `forum`.`dbopost` SET `userid` = '31582' WHERE `dbopost`.`userid` ='6644';

    the first user id is the newest id, and the second userid is the old one.

    I have used this on my board and it works perfect.

    Thanks for all the input on this matter.

    Dave

    Leave a comment:


  • Steve Machol
    replied
    I don't know of any way to make that work. Sorry.

    Leave a comment:


  • dbenton
    replied
    One more idea...

    Do you think it is possible to just run a query where we search for one user id and replace it with the one we want to keep? I was thinking and I thought it just might work.

    Leave a comment:


  • dbenton
    replied
    I have also asked him to see if he can maybe copy the vBulletin code to another folder / domain first to test that DB before we make the change. I would just like to know the old one will work properly. I am hoping that is "ok" in the vBulletin eyes. I know they made a few changes on their licensing, etc

    Leave a comment:


  • dbenton
    replied
    Thanks Zachary - I'll let him know and see what we can do

    Leave a comment:


  • Zachery
    replied
    Restore the backup and use it, optherwise theres nothing.

    Leave a comment:


  • dbenton
    replied
    I did see that ImpEx were listed on all the "old" users / moderators / admins Wayne

    Zachery - I am actually posting for the vBulletin License holder (David). I (Corey Bryant) used to have an honorary membership since I was administer / moderator on a lot of vBulletin forums but that seems to have changed.

    Anyway, in the event that ImpEx was ran - what needs to be done to fix it? I think he has a complete back up of the database before the move on / about 9 Mar

    Leave a comment:


  • Zachery
    replied
    how exactly did you move?

    Leave a comment:


  • Wayne Luke
    replied
    Sounds like you ran the user import module of ImpEx multiple times. This is the only thing that would account for new member IDs being generated. Normally when you move from one server to another, there is no need to run ImpEx for any reason.

    To restore this, you would have to restore your backup from before the move or manually change User IDs in the database.

    Leave a comment:


  • dbenton
    started a topic vBulletin Moved - Signatures Lost / Members Renumbered

    vBulletin Moved - Signatures Lost / Members Renumbered

    A forum was moved to a new server. But the old posts do not have the signatures. The old posts have n/a instead of the number of posts. And the reputation was lost. And they do not show a signature.

    All the new posts have the signatures and have the correct number of posts. When you search for a specific user, you only see posts from the day of the cutover. However, the all the posts are being seen in all the forums. I have done the 'Rebuild Thread Information', 'Rebuild Forum Information' and a few others.

    The thing I did see is I used to have ID 519, now I have 25473.

    Any direction at this point would be great. I know it is vBulletin 3.6.8 Patch Level 2
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X