Announcement

Collapse
No announcement yet.

showthread.php ignoring template divs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • showthread.php ignoring template divs

    So I'm creating a new template, and on the main pages forumdisplay.php and index.php it displays fine, looking like this:

    http://i28.tinypic.com/1042mf5.jpg

    This is created using an open div in the header file which is closed in the footer file so that everything in between falls within the parameters of the container (margins and so forth).

    However, when I open showthread.php, it displays like this:

    http://i28.tinypic.com/2mn511s.jpg

    So it looks like it's working as far as the navbar, but then messing it up somewhere underneath that. Oddly enough, the footer displays correctly on both pages.

    Any suggestions?

  • #2
    I suspect there is a problem with your content spacer. The showthread pages restart the spacer several times, unlike the forumdisplay and index pages. Check the header and footer to make sure they both have their spacer variables:

    Code:
    $spacer_open
    
    $spacer_close
    The spacer should be openned in the header and closed in the footer.

    Also make sure your outer div is outside of the content spacer variables (starts above $spacer_open and ends underneath $spacer_close).

    Comment


    • #3
      Thanks!

      That worked, spacer_close was already there in the footer file but completely missing in the header, so I added it immediately within the div that held the main page and now everything has aligned correctly, even the background has appeared where it was transparent before

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X