Announcement

Collapse
No announcement yet.

Can we use the clone procedure for our new site? And if yes, then how do we update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can we use the clone procedure for our new site? And if yes, then how do we update

    Can we use the clone procedure for our new site? And if yes, then how do we update the "License & Information".

    We bought a new vBulletin license for a new site ( which we want to be a copy/replica of the current live site )

    We do not want to start "install" from begining if possible => So can we use the procedure like "to create a test site" to copy and move all the data, plus hack, mods ..etc... of the current site ( still live and we want to keep it there) to new site (new domain -new host)

    And we will work on the new site further from there .

    Assume that everything went well ( ie clone procedure) .

    Next, our questions are :
    - How do we change the license information (to match with the new license we bough) if we use this procedure ?
    - And such procedure is OK with vBulletin regarding techical & license ... etc ?

    Regards,
    SilverB
    Last edited by SilverB; Fri 22nd Feb '08, 12:52pm.

  • #2
    As long as you have a valid license, you can have a development/test site. This must be in a directory called testvb and must not be publicly accessible - ie behind a htaccess login.

    To make an exact replica of your live forum, backup your database then restore it to the database to be used for your test forum. Copy all the files from your forum directory to the test forum location. Make sure you update config.php to connect to the correct database.
    Kerry-Anne :)

    Twitter Blog

    www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

    Comment


    • #3
      Dear Kerry_ Anne,

      Thank you for your instruction about make a "testvB" forum . Yes, this part I understand and we do have a valid VB license for the live forum that we want to make a replica .

      We also have another license (just bought from VB) and we intend to use this new vB license for the replica site if the testvB forum goes well .

      Another way of saying, we want to use mods, hacks... etc ... for our new forum, and avoid to start everything from the beginning. Plus, we want to use the data of the live (old) forum as well.

      My other question is, how do we update the licence information on that new forum (if we did not do the installation from the begining)?
      And would this appoach be OK regarding technical & license aspects with vB ?

      Thanks for your help

      Regards,
      SB

      Comment


      • #4
        Make sure that the License information in your members area is correct for the site for each license. Overwrite the vBulletin files with the files for the correct license. It doesn't affect the database so won't affect your data.
        Kerry-Anne :)

        Twitter Blog

        www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

        Comment


        • #5
          Dear Kerry_ Anne

          Thank you for your time & help

          Regards,
          SB

          Comment


          • #6
            Dear ALL,

            I follow the instruction in this thread
            http://www.vbulletin.com/forum/showt...51#post1469351
            to make "snap shot" testvb forum of my live forum. And I run into the problem below . Would someone with the knowledge help me to the right direction (to fix this problem) . Thank you in advance .

            Regards
            SB

            ************
            Warning: array_keys() [function.array-keys]: The first argument should be an array in /includes/functions.php on line 3863
            Warning: Invalid argument supplied for foreach() in /includes/functions.php on line 3863

            Sorry, the board is unavailable at the moment while we are testing some functionality.
            We will be back soon...
            *************
            Try to access the ACP I got this message

            Unable to add cookies, header already sent.
            File: /home/******/public_html/testvb/includes/class_core.php
            Line: 3075

            Comment


            • #7
              To troubleshoot this, please reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

              Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

              [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

              Next, disable all plugins.

              Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

              define('DISABLE_HOOKS', true);

              Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Now check again.

              Do you still have the same problem?
              Kerry-Anne :)

              Twitter Blog

              www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

              Comment


              • #8
                Dear Kerry_Anne

                To troubleshoot this, please reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:
                I did this part (ie reuploaded original files in ASCII format)

                Still see the same errors as in my previous post

                Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions
                Can not get into AdminCP => could not do this part

                ... Should stop here ... but I went on trying other steps for curiosity .. the same errors still there (I did cache the brownser)


                [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]
                Back up xml files and removed all files in this directory => still same error

                Next, disable all plugins.

                Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

                define('DISABLE_HOOKS', true);
                Did this one too => still same errors

                Regards,
                SB

                Comment


                • #9
                  You need to have the vBulletin xml files in the xml directory but remove xml files from any modifications. Please reupload the vBulletin files again.

                  Also, please check that there are no blank spaces or blank lines at the top of your config.php file before <?php
                  Kerry-Anne :)

                  Twitter Blog

                  www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

                  Comment


                  • #10
                    Originally posted by Kerry-Anne View Post
                    This must be in a directory called testvb and must not be publicly accessible - ie behind a htaccess login.
                    Is it a must that I will have to install the test/dev forum in testvb directory? I've installed it in http://dev.golpo.net

                    Comment


                    • #11
                      As per the license agreement it must be in a directory called testvb.
                      Kerry-Anne :)

                      Twitter Blog

                      www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X