Announcement

Collapse
No announcement yet.

database error help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • database error help

    I was trying to change my Signature Image Maximum Filesize (bytes) from 4 to 20 when click update i get a database error and it reverts back to 4.


    Invalid SQL:
    UPDATE VB_usergroup SET

    ### UPDATE QUERY GENERATED BY fetch_query_sql() ###
    `title` = 'Administrators',
    `description` = '',
    `usertitle` = 'Administrator',
    `opentag` = '',
    `closetag` = '',
    `passwordexpires` = '180',
    `passwordhistory` = '360',
    `forumpermissions` = '1048575',
    `genericpermissions` = '1073741759',
    `attachlimit` = '0',
    `pmquota` = '200',
    `pmpermissions` = '7',
    `pmsendmax` = '5',
    `calendarpermissions` = '63',
    `wolpermissions` = '31',
    `adminpermissions` = '3',
    `genericoptions` = '55',
    `profilepicmaxwidth` = '100',
    `profilepicmaxheight` = '100',
    `profilepicmaxsize` = '65535',
    `avatarmaxwidth` = '80',
    `avatarmaxheight` = '80',
    `avatarmaxsize` = '20000',

  • #2
    Invalid SQL errors are almost always related to modified code. To troubleshoot this, the first thing you need to do is remove any hacks or plugins, then see if you still have this problem.

    If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      yes steve still getting an error message, i did what you said even went and disable all my plugins. This is really confusing me.

      Comment


      • #4
        That error is from a modification.

        To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        Next, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Got everything fix, only got everything check in the that needed to be in the admin cp but when i upload it, it does not show??

          Comment


          • #6
            Upload what?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              When i upload the img of my signature i just see the code but the actually image doesn't show at all. everything is check like its suppose to in my admin cp

              Comment


              • #8
                You need to use the [sigpic] tag as explained here:

                http://www.vbulletin.com/forum/misc....=bbcode#sigpic
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                Loading...
                Working...
                X