Announcement

Collapse
No announcement yet.

Database access with Godaddy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database access with Godaddy

    When I am on step 3 of the installation process I get this error message:
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
    I have a shared hosting Linux account with Godaddy. When asked they said that due to security my problem is the port access. They recommened I get into the database (which I can do) and pull the upload files from there.
    Is there a workaround for this besides going to a dedicated server?
    Doug in AZ

  • #2
    You need to make sure that these four variables are correct:

    $config['MasterServer']['servername'] (except in rare cases, this should almost always be left as 'localhost' or '127.0.0.1')
    $config['MasterServer']['username']
    $config['MasterServer']['password']
    $config['Database']['dbname']

    For server name, GoDaddy is one of the rare cases. Your Master Server name will be something similar to pXXXmysql.secureserver.net. You can see this by clicking the configuration settings icon (its the pencil) in your database manager.

    Your database name and username will be the same at all times. Password is not shown but is what it is when you entered it. All three should be considered case sensitive. If you change the database/user name the database will be moved to a new server under their system so that would have to be updated as well.

    We have numerous customers using GoDaddy under their linux hosting without problems and without changing the port. If you have to change the port, then you can specify this in the config.php file under the master server name. This should be specified in the configuration settings as a :XXXX after the server name. The XXXX would be the port number.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      stumped by error message

      I have installed a new database (I'm using godaddy) and have gone over the config.php file to ensure that the information is correct. I have looked through the links you sent, the community threads and googled the phrases of the error message. Most seem to have luck when changing server name to "pXXXmysqlXXX.secureserver.net. This has not worked for me and at this point the only option I can think of is to ask other Godaddy shared hosting folks if they can look at their config.php file and see if they remember the trick. The quick install says it should take 5 minutes and I've been working on this for 2 days and have no options left. Godaddy database setup is nothing like the link I was emailed for examples in cpanel, plesk and ensim.
      Thanks in advance for any ideas.
      Doug in az

      Comment


      • #4
        I am at same problem doug. I have found the proper db master server name in my case p50mysql101.secureserver.net

        I still get the error as well. I have a feeling it may be port related. Should of went with the Linux Hoting.... hahahaha.

        Comment


        • #5
          To add....
          I have several Go Daddy domains. I ran my install against one of my Linux Hosted domains and once I changed the database name, master server name and master username the install went without a hitch! Imagine that.

          Comment


          • #6
            For anyone who wants to run this software make sure you get the LINUX Hosting package. I got this form GoDaddy support about my problem...


            "As long as you are using a Linux hosting account, you will be able to
            use the version_compare() function. If there is anything else that we
            may assist you with, please feel free to contact us via email or for a
            speedy response, you may call our support line at (480) 505-8877. We are
            available 24/7 for your convenience."


            Save yourself the trouble and get the LINUX HOSTING PACKAGE.

            Comment


            • #7
              I have godaddy shared Linux hosting. Try this. See what happens. This may not be your shared server but I think it's worth giving it a shot. I think they may use the same server name for all their Linux shared servers.

              $config['MasterServer']['servername'] = 'p50mysql61.secureserver.net';
              $config['MasterServer']['port'] = 3306;

              Mine works perfectly. Godaddy has been given a hard time by some users but their Linux shared server is pretty solid.

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X