Announcement

Collapse
No announcement yet.

Processes and memory shooting up and VPS SLM kicking in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Processes and memory shooting up and VPS SLM kicking in

    Ok, I have twice now in the last month had vBulletin start returning DB errors (I am not getting emails on these for some reason). When this happens, apparently my VPS is reaching it's memory limit and the SLM/Virtuozzo is killing processes.

    My host is saying that either my web traffic is overwhelming the site (not an issue) or the website programing is causing the problem. I only run vBulletin, and I am not aware of any known bugs in vBulletin that cause processes and memory to spiral out of control, but figured I would check here.

    Some stats. I am on 3.6.8 (release 2).

    I have 400 members, 270 active. I get 1500-1900 new posts a day, and most of the day I have 40-60 people 'active' at a time with an 1800 second timeout. The most ever online was 115 or so, and that was back in December.

    My VPS is 1152MB SLM guaranteed, and according to munin stat tracking, I have had at least 700mb of memory free/unused since I started tracking it 4 weeks ago.

    Apache/PHP: Apache/2.2.6 (Unix) mod_ssl/2.2.6 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 PHP/5.2.4

    MySQL: 5.0.45

    The only thing running on this VPS is vBulletin and email (associated with vBulletin).

    Any ideas you might have as to what could be causing this or how to troubleshoot would be greatly appreciated.
    BroncosForums.com - Broncos Fan Forum
    Total Broncos - Denver Broncos Blog and News

  • #2
    What does the output of top look like when your processes are getting killed off?
    Jason Litka - Utter Ramblings

    Comment


    • #3
      Originally posted by jason|xoxide View Post
      What does the output of top look like when your processes are getting killed off?
      I am not 100% sure. Server went down at 4:53 and it took me a while to wake up to the pages. At 5:30 or so, I went and checked, and I had top up on one screen. I glanced at it and it looked normal. When I tried the forced reboot, it disconnected putty and the image is frozen at that point.

      What is showing on putty (which i hadn't restarted) is:

      server loa worked, i had to restart the VPS from the virtuozzo control panel.d was near .39, .78, .76, the only active processes it was showing was "top".

      813748k free memory, 365900k used memory. CPU use 0.0%.

      111 tasks, 1 running, 109 sleeping, 0 stopped, 1 zombie

      I cannot say if at this time SLM was still killing off threads, but I do know that vBulletin was giving DB errors and neither a graceful or forceful restart (from WHM)
      BroncosForums.com - Broncos Fan Forum
      Total Broncos - Denver Broncos Blog and News

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X