Announcement

Collapse
No announcement yet.

Post Table Crashed ?!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Post Table Crashed ?!

    few days ago the POST table of our forum crashed for no reason that we know of, so the forum is up and running except when we click on any of the forum sections like "general discussion" etc we get a database error saying:

    MySQL Error : Table 'post' is marked as crashed and last (automatic?) repair failed

    any help would be greatly appreciate it in fixing out database..

    Thanks

  • #2
    Go to the Maintenance section of your Admin CP and then Repair/Optimize Tables. Select the post table and then select Repair. You may have to run it a couple of times. You may want to also Optimize it.

    Please don't PM or VM me for support - I only help out in the threads.
    vBulletin Manual & vBulletin 4.0 Code Documentation (API)
    Want help modifying your vbulletin forum? Head on over to vbulletin.org
    If I post CSS and you don't know where it goes, throw it into the additional.css template.

    W3Schools <- awesome site for html/css help

    Comment


    • #3
      hello
      I've done that many times it keeps giving me errors on that process saying the post count is 234234 and should be 0 !, and it also says that it has crashed and can't be repaird etc..

      and everytime we run the replair script in the adminCP our /tmp folder in the linux machine gets maxed out:

      /tmp 1012M 961M 0 100% /var/tmp

      Comment


      • #4
        The volume holding your temp folder for MySQL (/tmp by default) needs to be at least 3x the size of the size of the broken table in order for the repair to succeed.

        If your /tmp partition is not large enough then you should temporarily move your MySQL temp folder to another volume so the repair can be completed.
        Jason Litka - Utter Ramblings

        Comment


        • #5
          thanks for the hint. how do you change the temp folder of mysql on linux fedora core

          Comment


          • #6
            The following assumes that your / partition has enough free space. If it doesn't, change the path I specified to something else.
            1. Log into your server as 'root' (directly, su, or sudo, it doesn't matter)
            2. Run "mkdir /mysqltemp"
            3. Edit your /etc/my.cnf file and add "tmpdir = /mysqltemp"
            4. Run "service mysqld restart"
            5. Run your table repair
            6. Edit your /etc/my.cnf file and remove the "tmpdir" line
            7. Run "service mysqld restart"
            Jason Litka - Utter Ramblings

            Comment


            • #7
              did that and still writes to the /var/tmp folder ?!!

              Comment


              • #8
                Was there already a "tmpdir" line in your my.cnf? Did you restart mysqld after making the change?
                Jason Litka - Utter Ramblings

                Comment


                • #9
                  no there was no tmpdir line
                  and yes I did restart the mysql service

                  Comment


                  • #10
                    thanks guys
                    got it fixed.. by changing the tmp folder and repairing the db :PPPPp

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X