Announcement

Collapse
No announcement yet.

$config dbtype 'mysqli' - if PHP version is prior to 5. ?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • $config dbtype 'mysqli' - if PHP version is prior to 5. ?

    $config['Database']['dbtype']

    If you are using PHP5 in combination with MySQL 4.1.x you may want to change this variable to 'mysqli' to take advantage of the MySQL Improved engine

    http://www.vbulletin.com/docs/html/main/editconfig

    My host (LunarPages) has PHP4.4.8 (and mySQL 5.0.45). Will that still qualify for mysqli?
    Last edited by SpreadingLight; Tue 22 Jan '08, 11:12pm. Reason: added url

  • #2
    Leave it at mysql unless you are sure it will work otherwise you will receive errors.

    Comment


    • #3
      Thanks I'm NEW at all this, so I appreciate the community.


      I was searching online and saw this at http://www.php.net/manual/en/ref.mysqli.php

      Note: The mysqli extension is designed to work with the version 4.1.3 or above of MySQL. For previous versions, please see the MySQL extension documentation.
      So I'm wondering whether to follow the req's of php.net or vB...

      Comment


      • #4
        No worries. Leaving it at the default mysql setting will not cause any problems and your forums will run fine with it like that.

        Comment


        • #5
          My Host help just said they allow users to enable php5.

          It looks like a clear choice to me (at least from these numbers)www.sourcelabs.com/pdfs/SourceLabsPHP4vsPHP5.pdf

          Comment


          • #6
            Originally posted by SpreadingLight View Post
            My Host help just said they allow users to enable php5.

            It looks like a clear choice to me (at least from these numbers)www.sourcelabs.com/pdfs/SourceLabsPHP4vsPHP5.pdf
            In defense of PHP 4, 4.4.x is faster than 4.3.x. Then again, 5.2.x is WAY faster than 5.0.x (fast but crash-happy) and 5.1.x (slower than 5.0.x but more stable).
            Jason Litka - Utter Ramblings

            Comment


            • #7
              You cannot use mysqli with PHP 4.4.8. It is only available with PHP 5 and higher.
              Translations provided by Google.

              Wayne Luke
              The Rabid Badger - a vBulletin Cloud demonstration site.
              vBulletin 5 API

              Comment


              • #8
                I have 5.2.5 now. Hopefully, it's in the "fast but not crash-happy" category?

                Comment


                • #9
                  Yes, 5.2.x is faster than 5.0.x and 5.1.x and is very stable.
                  Jason Litka - Utter Ramblings

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X