Announcement

Collapse
No announcement yet.

User Promotions not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • User Promotions not working

    Everything was working fine, but now all of a sudden the user promotions stopped working. Heres the details of whats happening:

    User promotion cron set to run every 25 mins, and it runs every 25 mins however nothing happens. The last time the log shows that it ran was May 16th 2007. When I go to run it manually I get a blank page that just says User Promotions on the top of the page. Running VB version 3.6.4

    I have tried deleting the user promotion and re-adding it, also tried disabling the user promotion and re-enabling it. Also tried checking the permissions on the file for the promotions and its the same as the other ones that are working. Also note that every other cron is working just fine, this is the only one thats not working.


  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      You might want to see a similar thread I started about this: http://www.vbulletin.com/forum/showthread.php?t=251851 I had upgraded from 3.0.12 to 3.6.8 and they changed (or actually, fixed) the query that does the permissions. It only promotes users who visit your forum again, not like the old way of promoting all users who meet the criteria.

      Please don't PM or VM me for support - I only help out in the threads.
      vBulletin Manual & vBulletin 4.0 Code Documentation (API)
      Want help modifying your vbulletin forum? Head on over to vbulletin.org
      If I post CSS and you don't know where it goes, throw it into the additional.css template.

      W3Schools &lt;- awesome site for html/css help

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X