Announcement

Collapse
No announcement yet.

Database crashed, and I can’t repair it.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database crashed, and I can’t repair it.

    A few days ago I upgraded to version 3.6.8 patch 2, and everything worked fine. When I logged in today the database had crashed, nothing new there, and I could not access the admin control panel either, which is also not unusual for me anymore. I logged in to cPanel, repaired the database like I usually do, but it is still crashed. cPanel reports everything was repaired, but the database does not work. The usual $message portion of the error page is not showing up, except once, and it shows my error as:
    PHP Code:
    MySQL Error  Table './rs_database/session' is marked as crashed and should be repaired Error Number 145 
    cPanel tells me all tables are fine, and I have run multiple repairs, but it is still crashed. How the heck can I repair this? The extent of my experience with mysql is limited to pressing the usual buttons on the admin cp and cPanel to fix stuff. I gather I will have to run a query, but I have no idea what the proper syntax should be. Can anyone lend assistance? Edit: I don't know what is going with the paragraph breaks here, I can't edit it!
    Last edited by tm21; Sat 12 Jan '08, 3:34am. Reason: My paragraph breaks keep getting deleted...

  • #2
    Try getting into phpMyadmin if you have it, it is normally accessible within cPanel. then go into your database and run an SQL query:
    Code:
    REPAIR TABLE session
    MARK.B | vBULLETIN SUPPORT

    TalkNewsUK - My vBulletin 5.6.3 Demo
    AdminAmmo - My Cloud Demo

    Comment


    • #3
      I do have phpMyAdmin, and I ran the repair query, but the database was still crashed. A check of the session table reports that it is OK, but if I try to backup my database from shell it will not let because that table is crashed. While wandering aimlessly for assistance I came across this thread:
      http://www.vbulletin.com/forum/showthread.php?t=255574
      which offered a nice way to use shell access to try to fix the tables.

      I was able to use the command "REPAIR TABLE session" after logging in to the database sql thing like it said in the above thread. After a few minutes wondering why that command didn't seem to work I discovered I had to end my command with \g instead of a ;

      I experienced a second error on a different table, easily fixed, then a few timeout errors, but after a few minutes everything seemed to work properly again. I think I will try to brush up on how to use phpMyAdmin, it seems like it can help me optimize the database better.

      Comment


      • #4
        Most important thing you can do is make a backup. Don't forget to do that.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X