Announcement

Collapse
No announcement yet.

Attachment Storage Change Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • qbonoguy
    replied
    What did you end up putting as your path? I can't get mine to work either...

    Safe Mode = Off

    Chmod 777 my attachment directory

    Chown to the correct values

    My forum is at /forum and my attachment directory is /forum/_files/attachments

    but when I try to upload an attachment I get "File system directory is not writable."

    Leave a comment:


  • Lois215
    replied
    Goodness.....I finally figured it out. Thanks for your help. I knew it had to be user error somewhere as this board system works quite well!

    Leave a comment:


  • Lois215
    replied
    Yes, I did. I thought I was supposed to. So if my site was at www.nameremoved.org, would the path name be /home/nameremoved/attachments? If so, that didn't work. Or would it be something else?

    I am probably going to kick myself when I find out how simple this is to do!

    Leave a comment:


  • Lynne
    replied
    Originally posted by Lois215 View Post
    No matter where I try to place the attachment folder, it gives the same message:
    We attempted to write a test file to /www.nameremoved.org/attachmentsck/board, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.
    Did you really write "www.yoursitename.org" in the path cuz I would guess that is the problem. I'm on a Linux server, and my path goes something like "/home/mysitename/attachments", it shouldn't have something that looks like a url in there.

    Leave a comment:


  • Lois215
    replied
    Thanks so much, Steve. You helped on an installation question I had and your response fixed the difficulty.

    I don't want attachments stored in my database as my website host gives me less database space than other space. So having attachments kept in a file will greatly ease the load on my new vBulletin board.

    I have looked all over in the manual and tried some searching here, but cannot figure out what I am doing wrong or what needs to be done so this will work.

    No matter where I try to place the attachment folder, it gives the same message:
    We attempted to write a test file to /www.nameremoved.org/attachmentsck/board, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.

    I tried placing it above my main site, in the site (I can disable others through .htaccess) and in my vBulletin folder. None of the options will work.

    In checking here, I saw to use the 777 settings, which I did. I also saw to check if safe mode is on and it is not. I believe the site runs on a Linux server.

    Wayne Luke gave a suggestion in this thread, but I have no idea how to do it. I am a learn as I go along person and am not well versed in coding and such.

    Any suggestions would be greatly appreciated as I turned off the feature to members until I can figure out what I am doing wrong.

    Leave a comment:


  • Steve Machol
    replied
    It works if done right. Could you please start from the beginning and provide all the relevant details?

    Leave a comment:


  • Lois215
    replied
    Is there someone out there that can help me with this? Please???

    Leave a comment:


  • Lois215
    replied
    Does anyone else have any suggestions, or details on how to do what Wayne Luke suggested? To create the files, I simply used an FTP program and set each folder to 777 as stated. So I don't know how to go about doing what was suggested.

    Leave a comment:


  • Lois215
    replied
    I am still perplexed as to what is wrong. I had to disable attachments on the board and blogs until I can figure out what I am either doing wrong or what the problem is.

    Leave a comment:


  • Lois215
    replied
    Sorry- I am not quite sure what you mean. I just set the directories up via FTP. Bear with me- I am just a learn as I go along person!

    No matter where I put it- above my main site, in it and even in the vBulletin directories, it gives the same message.

    Leave a comment:


  • Wayne Luke
    replied
    Make sure that the storage directory is owned by the webserver user and group. You can change this with CHOWN at the command line.

    Leave a comment:


  • Lois215
    started a topic Attachment Storage Change Question

    Attachment Storage Change Question

    I recently set up a new board and transferred things over from my old board. That all went well. However, I am having trouble changing the attachment settings to be saved in a file instead of the database. It seems so matter what I do, I get the same message:


    We attempted to write a test file to /www.nameremoved.org/attachmentsck/board, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.

    It seems no matter where I install the attachments folder, it doesn't work. It is all set to 777. Safe mode is off.

    Suggestions?

    BTW, I absolutely love vBulletin. I had used a free board in the past (phpBB2) & there is a night and day difference between them. I'm extremely pleased with the board and with the support here.
    Last edited by Lois215; Sun 6 Jan '08, 5:05pm.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X