Announcement

Collapse
No announcement yet.

Avatars default directory?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avatars default directory?

    Hi,

    I see that there are two directories for avatars:

    /forum/customavatars
    /forum/images/avatars

    I think I messed up my Avatar manager files. I just want people to be able to upload their own to the server but am not sure which file to point it to?

    ./customavatars?
    ./images/avatars?
    Paula

  • #2
    customavatars is normally for user-uploaded avatars.

    images/avatars is normally for premade avatars that the admin uploads for people to choose from:

    Admin CP -> Avatars

    Comment


    • #3
      Ok.

      Avatars are enabled.

      In User Picture Storage Type, I have:

      Avatar File Path = ./customavatars
      URL to avatars = customavatars

      Is this correct?

      After trying to upload I get:
      Unable to move/copy file
      Paula

      Comment


      • #4
        It looks correct. Just be sure that the directory does exist and it is set to 0777 to allow it to be write-able.

        Comment


        • #5
          Yep, what DoE said.

          Comment


          • #6
            Thanks!
            Paula

            Comment


            • #7
              0777 or 777? Does it matter?
              Paula

              Comment


              • #8
                It's the same thing.

                Comment


                • #9
                  Permissions were set to (rwxrwxrwx) on forum/customavatars but am still getting "Unable to move/copy file".

                  Can someone walk me through all settings, please?
                  Paula

                  Comment


                  • #10
                    Try doing a test upload:

                    Admin CP -> Maintenance -> Diagnostics -> Upload

                    Does the test report any errors? If nothing is forthcoming then we can take a look if you submit a trouble ticket with your forum and server info:

                    http://members.vbulletin.com/members...ontactform.php

                    Comment


                    • #11
                      Pertinent PHP Settings
                      file_uploads: On
                      open_basedir: None
                      safe_mode: On
                      upload_tmp_dir: None
                      upload_max_filesize: 2.00 MB

                      Results
                      No errors occurred while opening the uploaded file for reading. You should be able to turn off the "Upload In Safe Mode?" option without any adverse effects.
                      Paula

                      Comment


                      • #12
                        The test indicates that safe mode is enabled. Try turning it off:

                        Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Safe Mode Upload Enabled

                        Comment


                        • #13
                          Also another possible cause of that specific error is that is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.

                          You will also need to restart Apache after making this change.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Thanks again guys!

                            I have another question:

                            When one goes to the UserCP to edit avatar, it shows that they can either upload an avatar or place a link to one. I would like to disable the latter (option 2) and wondered how to do that?
                            Paula

                            Comment


                            • #15
                              There is no setting for that. You would have to manually edit it out of the templates.
                              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                              Change CKEditor Colors to Match Style (for 4.1.4 and above)

                              Steve Machol Photography


                              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                              Comment

                              Loading...
                              Working...
                              X