Announcement

Collapse
No announcement yet.

Can not add forums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not add forums

    I tried to add another forum in my Admincp and it will not let me add one. It tells me when I one "Saved Forum Name Successfully" but it does not create the forum. I don't know why I can not do this. I have other VB forums on this server and I have no problems adding new forums in the Admincp.

    Does anyone know what would cause this?

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Steve

      If my databasestore_cache.php file is not 777 will this cause this?

      Comment


      • #4
        It could.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Yes this was what caused my problem. After I disabled it in my config file everything started working properly again.

          Could someone please explain the advantages and disadvantages of using the datastore_cache.php file?

          Comment


          • #6
            The different types of datastore caching and their individual advantages can be found here:
            http://www.vbulletin.com/docs/html/datastore
            Kerry-Anne :)

            Twitter Blog

            www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

            Comment


            • #7
              Yes I did read those, thank you. What are the advantages to using it and when should it be used?

              Comment


              • #8
                Steve

                I am hoping you read this because I would like to here your take on this.

                I had my server guys look into this problem and they told me it was a VB issue and not a server issue. This is what they said.

                Everytime you save the file the function build_forum_permissions was executed which resets the permission of the file to 644. This is the vbullient php function. I edited the file forum.php and disabled the function for "save".
                Is this true? I am not happy with them changing my forum.php file but why are we suppose to set the databasestore_cache.php file to 777 if this happens changing it back to 644 so it in no longer writeable.

                Comment


                • #9
                  No, there is nothing in vBthat would change the file permissions. More likely the umask setting for that directory is set to automatically change the permissions everytime the file is saved. Ask your host to fix this.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Steve

                    I hope you still checking in on this thread. I have had my server management team check the unmask settings and they change some of them. Here is what they told me they did.
                    I have changed the unmask for the user nobody as 000 which should resolve your issue. Please check it and if the problem persists please let me know.

                    Also can you please explain why you need to set 777 permission for the file databasestore_cache.php. Most of the php file works with the permission 644.
                    The problem is that every time I go into my Admincp and change something the change doe not show up in my admincp and the file reverts back to 644. If I comment out the line in my config.php then everything works fine. My server management team is not understanding this either. They seem to think it is a VB issue.

                    Comment


                    • #11
                      vB has absolutely no code in it that changes file permissions - none at all. I'm afraid this remains a server issue.

                      If your host can't fix this then you should turn the databstore file caching system off.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        I know turning the datastore caching off works. I have turned it off and it works like a charm. I have a fairly large database and I want to get this working again to keep the loads off the database and to keep the querying down on the database.

                        I have a good server management team (or so I thought). I just do not know where to turn to now to get this resolved.

                        Comment


                        • #13
                          Steve

                          I am still having problems with this. I have a question to ask you that I need clarification on. Why does the file have to be 777? My server management crew is trying to tell me I should be able to do everything I need to do with 644. I told them it has to be 777. Could you please explain to me why it has to be 777 so I can relay this to my server management team? This is what they replied to me below.

                          It is normal that a file when saved using a browser will revert the permission to 644 and the ownership will be nobody:nobody. Any users will be able to read and write to that file as the user ownership is nobody. By giving 777 permission the file will be having execute permission, but I dont think that execute permission is necessary for a php file as it works well with 644 permission.

                          Comment


                          • #14
                            It has to be 777 because it needs to be world-writable. Once it's changed to 644 by the server, vB can no longer write to it, hence the the error you are getting.

                            Your choices are:

                            1. Your host fixes whatever is causing the server to change the file permissions.

                            2. Don't use the file datastore cache.

                            3. Find another host.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              I'd recommend find another host.

                              1 and 1 hosting, 5 bucks a month, a ton of bandwith, and they don't mess with your vb at all.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X