No announcement yet.

RSS feed - XML Error comment not finished

  • Filter
  • Time
  • Show
Clear All
new posts

  • RSS feed - XML Error comment not finished

    I am running vB version 3.65 and I’m having trouble with an RSS feed.
    The error message I’m getting is,"XML Error: Comment not finished at Line 9"
    The feed URL is:

    Oddly, this has been working fine for months and then a few weeks ago this error started. I have not applied any add-ons, plug-ins, or hacks or any kind. I have not changed a thing - so I suspected it might be a maintenance issue, or maybe related to a server variable. However, I do have other feeds from other sources that work fine.

    I submitted this to vB support, and the suggestion was that I upgrade. I fear that might introduce more issues than it solves... so I’m just looking for a fix. I’ve tried to delete the feed and re-added it but still the same issue. Any suggestions?

  • #2
    It may a server issue from the other end, as I can get ti to work.. Are you still experiencing this problem.


    • #3
      I upgraded to 3.6.8, and yes, I’m STILL experiencing the same problem. I contacted the web host and they have not found any server issues. So far vB support has not been able to resolve this. When you say you can get it to work... does that mean you were able to preview the feed by creating it in the vBulletin RSS Feed manager? Or did you just access the RSS URL in your browser?


      • #4
        It works fine for me too. Make sure you clear your cache before trying it out cuz otherwise you will get the same error page.

        Please don't PM or VM me for support - I only help out in the threads.
        vBulletin Manual & vBulletin 4.0 Code Documentation (API)
        Want help modifying your vbulletin forum? Head on over to
        If I post CSS and you don't know where it goes, throw it into the additional.css template.

        W3Schools <- awesome site for html/css help


        • #5
          Works fine for me too. IE7.0


          • #6
            Thanks for the feedback. Would you mind telling me what hosting company you use, or what version of PHP you are running?

            My feeds were working at PHP 5.2.0 but after an update to PHP 5.2.2 the errors started. Could just be a coincidence.


            • #7
              In many cases this is caused by a bad item in the RSS Feed and the error will clear when the affected item drops off the feed.


              • #8
                That is probably true, but it does not apply in this case. The reason I say that is because I was able to access the rss link in my browser and I saved the XML file moving it to a folder on my site. I then ran the RSS Feed Preview against this file and it worked just fine. So if the XML file is not being parsed properly it obviously is not the vBulletin software or actual XML data. Also, my other RSS feeds are having similar problems.

                The hosting company (called Netfirms) keeps telling me the process is timing out. My response is, Holy Cow - the XML file is less than 15kb. If the server can’t handle that - they should not be running a hosting service.

                They have been working on this issue for weeks and still haven’t figured it out. So needless to say I’m looking for another hosting service.


                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.