Announcement

Collapse
No announcement yet.

White screens?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • White screens?

    We migrated our web site to a Windows 2003 server a few months back, everything has been fine, and pretty much still is!

    However we are getting some complaints that when uses are browsing, trying to post (to new and old threads) they're waiting for a response ("web site found, waiting for reply.." etc.) then a white screen appears and the page stops loading. I've had this myself once or twice while browsing the web site.

    What prompted me to post on here was a user posted in an already existing thread and was shown a white screen after submitting his post. The post appeared in the thread, but it did not register as a new post in the "new posts" search or the thread listing on forum display.

    We're running Windows 2003, IIS6, PHP5 and MySQL5.

    If anyone has any suggestions as to why this is randomly happening, please let me know!
    Last edited by stuuu; Wed 19 Dec '07, 9:11am. Reason: Typo

  • #2
    Try adding this line to the includes/config.php file:

    Code:
    ini_set('display_errors', true);
    Does the white page show any specific errors now?

    _____

    If the white screen is happening after a long page load then the script might be hitting a time limit or memory limit. Adding these lines to the config file might resolve it:

    Code:
    ini_set('max_execution_time', 5000);
    ini_set('memory_limit', '64M');
    _____

    Then of course you can try removing any customizations to see if that fixes it. Try to reproduce it on a default style:

    Admin CP -> Styles & Templates -> Style Manager -> [Add New Style]

    Create a new style with no parent. Then click that style's name in the Style Manager to view your forum with that style.

    If you still have the problem then try disabling your plugins:

    Admin CP -> vBulletin Options -> Plugin/Hook System

    Also run a file check to look for customized files:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Comment


    • #3
      Thanks

      Thanks Jake:

      I am glad I used the search function.

      Your answer solved the problems I had on my site for the search function.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X