Announcement

Collapse
No announcement yet.

Username search results

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Username search results

    I recently noticed that on a couple of users when doing searches for their posts the results stop with threads from a couple of months ago even though they have posted many times since then.

    The only common thing I can think of is that I manually changed their posts counts a while and I think it corresponds to the time the results stop. I have tried various maintenance actions with no results.

  • #2
    Admin CP -> vBulletin Options -> Message Searching Options -> Maximum Search Results to Return

    If you make this too high, it could cause significant load issues.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      thanks but that is not the problem

      I looked again and it seems newer posts are also showing up but they are not in descending order of last post as checked in the search options but they are scattered.

      Comment


      • #4
        Not sure I undderstand. Can you duplicate this here?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Sure, go to this link http://www.sfzcc.com/forum/search.php?searchid=35319

          it is a search result with the option of displaying in "last posting date" in "descending" order checked but the results are random in date.

          just realized you probably can't see it without being registered it so I will copy and paste

          Comment


          • #6
            see attachment
            Attached Files

            Comment


            • #7
              What I meant was can you duplicate this issue on these forums?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                sorry, no.

                when I search using other usernames the posts show up in chronological order it is just these two users I manually adjusted post counts a while back that the posts show up in random order

                Comment


                • #9
                  What 'Sort Results By' setting are you using?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Steve Machol View Post
                    What 'Sort Results By' setting are you using?
                    Originally posted by westpak View Post
                    ...........
                    it is a search result with the option of displaying in "last posting date" in "descending" order checked but the results are random in date.

                    ............
                    ^^^^^

                    Comment


                    • #11
                      I really don't know what to suggest then. It must be due to the modification you talked about.
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        From what it looks like, your Search Results are in order by chronological order by posts not their created threads and is not set to "Show Results as Posts", by the order of when Gators2001 posted. It is not in order of the last reply in the thread.
                        I can duplicate this on my friends forum.

                        I believe the feature is working as it is supposed to be. Listing as Gators2001's post time.
                        Last edited by SNN; Fri 14 Dec '07, 7:03pm.

                        Comment


                        • #13
                          the thing is that it only happens with two users, gators2001 being one of them, and if you do a search to show results as posts the first post shown is in October although he has posted many times since then.

                          Comment


                          • #14
                            I just noticed that with these two users the search results say:

                            search took xx seconds: generated xxxxx minute(s) ago

                            but with all other users it just says:

                            search took xx seconds

                            Comment


                            • #15
                              OK I guess no one has an answer, but here is some pieces of the puzzle to see if it helps.

                              The random results and search took xx seconds: generated xxxxx minute(s) ago message only happens when the search requirement of Find Posts from ANY DATE and NEWER is used if I pick 3 MONTHS and NEWER or anything else besides ANY DATE the results are in order and the generated xxxxx minute(s) ago message doesn't apear, again this only hapens with some users not all

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X