Announcement

Collapse
No announcement yet.

How do I: Set up RSS Feeds on my forum?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • qbonoguy
    replied
    Fortunately, I did not have to disable all of my add-ons!!!

    Here is what fixed it...

    By default vBulletin is configured to only show RSS feeds for threads that have had activity within the last 30 days. Many of my threads have not had activity in the past 30 days. To change the options...

    ACP => vBulletin Options => External Data Provider => Thread Cutoff

    Thanks to Kevin at the Cinvin forum for pointing this out...

    Leave a comment:


  • qbonoguy
    replied
    I guess I'll have to put a beta site together... the add-ons are important as my registration rates have increased significantly since installing them and after a few years of ranking 0 on Google Pagerank I've at least made it to 1 just a few months after installing vbSEO... moral of the story is that these features should become a part of the standard vB installation... anyway, let me work on getting that beta site together... I just don't have much time to put into debugging problems, so I really appreciate your help!

    Leave a comment:


  • Andy Huang
    replied
    Also, to add to the previous reply, your normal RSS does work; but you need to disable all your plugins first. Instruction as to how to do so via config.php is included earlier this thread.

    Once you've done that, point your browser to, for example, http://www.mlmstuff.com/forum/external.php?forumids=53

    You will see right now an error because there is a faulty addon right now causing problem. Once you disable all plugins (or you can just disable the one that is causing problem, you can figure this out by disabling them individually and then go back to try the page), it will work, as you can already see normal output at the bottom of the error when you go view page source on that page.

    Leave a comment:


  • Andy Huang
    replied
    cv_rss_feeds.php is a customized script for the site above and is not part of the standard vbulletin options. You will need to contact the site's owner for further details in regards to that script.

    Leave a comment:


  • Steve Machol
    replied
    Remove all add-ons, restore the original vB files then if you still have this problem after that please start your own thread with all the relevant details.

    Leave a comment:


  • qbonoguy
    replied
    That's what I meant... Individual forum level...

    http://www.mlmstuff.com/forum/cv_rss_feeds.php

    Leave a comment:


  • Andy Huang
    replied
    What do you mean by individual thread feeds? There is no feed at per thread level, only per forum (or forums) level.

    Leave a comment:


  • qbonoguy
    replied
    No, I disabled it and it the individual thread feeds still do not work... it is currently disabled...

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by qbonoguy View Post
    I'm having problems also...

    If I turn off my Limited Guest Viewing plug-in my normal external.php file starts working...

    http://www.mlmstuff.com/forum/external.php

    But none of the individual forum feeds works... they are all blank...

    http://www.mlmstuff.com/forum/external.php?forumids=68

    I tried disabling vbSEO but that did not change anything...

    What else can I look at to get my individual forum feeds working? Also, is there any way to limit guest viewing and have the rss feeds work still?
    By your on addmission this is a problem with the Limited Guest Viewing plug-in. You should ask over at www.vbulletin.org.

    Leave a comment:


  • qbonoguy
    replied
    I'm having problems also...

    If I turn off my Limited Guest Viewing plug-in my normal external.php file starts working...

    http://www.mlmstuff.com/forum/external.php

    But none of the individual forum feeds work... they are all blank...

    http://www.mlmstuff.com/forum/external.php?forumids=68

    I tried disabling vbSEO but that did not change anything...

    What else can I look at to get my individual forum feeds working? Also, is there any way to limit guest viewing and have the rss feeds work still?

    Leave a comment:


  • Joshyyy
    replied
    Thanks for your help guys, much appreciated.

    Leave a comment:


  • Steve Machol
    replied
    Either your RSS feeds are not enabled, or you have made a modification to break this.

    Admin CP -> vBulletin Options -> External Data Provider -> Enable RSS Syndication -> Yes

    Then if you still have this problem, eupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

    Leave a comment:


  • Mr. Fancy Pants
    replied
    Questions & Feedback
    For Sale
    Wanted

    Leave a comment:


  • Steve Machol
    replied
    What forum can guests view threads in? IE does not detect a valid RSS feed on your site.

    Leave a comment:


  • Mr. Fancy Pants
    replied
    www.i-sportbike.com/forum/index.php

    let me know if you need a user name to use..

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X