Announcement

Collapse
No announcement yet.

Search problem - cached searches

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Search problem - cached searches

    Just recently upgraded to 3.6.8p2 and I seem to be having trouble with cached searches. This never came up prior to upgrading so I assume it started there. When users are do a search on their username if they had done the same search yesterday for example the results come up as yesterdays search. So posts they've made since that last search don't come up in their results. I've been able to replicate the problem by searching on their name as well and I get the same results. If I wipe out the search table then the more recent posts come up in the searches as well. Two users have come up with this problem. I thought maybe it was just a problem with the search table so I wiped it but one of the two users had it happen to him again today. Anyone else seeing this problem?
    -Steve St.Laurent
    Webmaster of http://www.turbodieselregister.com

  • #2
    I haven't heard of this but suggest running a repair and optimize on the search table to make sure it is getting updated properly.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      I've tried that and we'll see what happens.
      -Steve St.Laurent
      Webmaster of http://www.turbodieselregister.com

      Comment


      • #4
        Actually, I just tried it and I was able to replicate the problem here on this site so it must be a code issue in vB. Pull down the search menu and do an advanced search. Search on your own username. Now reply to a post that you haven't previously posted to. Now do another advanced search on your username - that post that you just posted to won't come up on that search, it's loading the search results from the first time you did the search.
        -Steve St.Laurent
        Webmaster of http://www.turbodieselregister.com

        Comment


        • #5
          Try turning off "Search Result Sharing". You can do this under vBulletin Options -> Message Searching Options.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Tried that but it still does it. As I said above you can duplicate this problem here on 3.7 as well.
            -Steve St.Laurent
            Webmaster of http://www.turbodieselregister.com

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X