Announcement

Collapse
No announcement yet.

vB won't accept large attachments again. Ugh!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    If you have not installed any add-ons, fill out a support ticket at:

    http://members.vbulletin.com/members...ontactform.php

    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.

    Leave a comment:


  • Factory Ten
    replied
    Originally posted by joelcont View Post
    i am pretty sure is the host..... there is nothing more i can think of .. and confirm it installin vb on a free host or on any other host u got ...
    I had that same thought but my host confirms that other people are running vB on the same machine that my site is on. I'm thinking of paying another host for a month's service and trying that out.

    Leave a comment:


  • joelcont
    replied
    i am pretty sure is the host..... there is nothing more i can think of .. and confirm it installin vb on a free host or on any other host u got ...

    Leave a comment:


  • Factory Ten
    replied
    Originally posted by Steve Machol View Post
    I thought it wwas already estalished that one of your add-ons is causing this? It's not something that happens with the default vB code.
    No. I'm sorry if my previous two posts were a little unclear.

    I deleted everything from my website and flushed the database. I then reinstalled vB. Basically its a brand-new fresh installation. I did not install any add-ons, themes or anything else. I did go into the Attachments Manager of my ACP and increased the size of allowed attachments.

    This was the only change I made from the default vB installation.

    After that I was no longer able to upload anything over about 40k. In other words this problem happens when I adjust the settings in the Attachment Manager and isn't related to one of the Add-Ons, as I'd previously suspected.

    Any thoughts on this?

    Leave a comment:


  • Steve Machol
    replied
    I thought it wwas already estalished that one of your add-ons is causing this? It's not something that happens with the default vB code.

    Leave a comment:


  • Factory Ten
    replied
    Any thoughts?

    Leave a comment:


  • Factory Ten
    replied
    Good morning.

    The installation on my Mac wasn't working as well as I'd hope. I'd have to install a bunch of PHP libraries and I don't have the time to do that.

    So what I did was this: I deleted ALL the vB files from my website, and erased the database. Then I did a full install. Everything is fresh. I went into the ACP and changed some numbers for the Attachments. Then when I tried to upload a file, it won't go past 40k.

    It seems that somehow changing things in the Attachments Manager breaks my vB site. Any idea of what this could be?

    Edit: When I upload a zipped version of a JPG, it uploads fine, providing its under the vB default size of 100k. But uploading the JPG version doesn't work. It seems that the changed values for the Attachment Manager are breaking vB somehow. Any thoughts?
    Last edited by Factory Ten; Tue 16 Oct '07, 11:25am.

    Leave a comment:


  • Factory Ten
    replied
    Well...I uploaded some Smilies, removed the No Plugins code from my config.php and now I'm having the same issue again.

    I put the config.php code back in and reuploaded it but no love. I cannot imagine why this is going to work for a few minutes then suddenly cease working.

    Edit: Actually I just had a thought: to see if its my webhost, or possibly my odd router, is it possible to install my vB site on my Mac and see how that goes? If it runs fine there than we know its not a vB issue and I can deal with that. If it doesn't run fine than something is messed up on th vB side of things and we can track that down. I have MySQL and PHP already installed on my Mac. How can I transfer my vB site to my Mac?

    I think I've found instructions on moving my database to my Mac. I'll play around with this when I wake up in the morning. G'night.
    Last edited by Factory Ten; Mon 15 Oct '07, 11:33pm.

    Leave a comment:


  • Steve Machol
    replied
    Try enabling one add-on at a time to see which one caused this.

    Leave a comment:


  • Factory Ten
    replied
    Okay right now everything seems to be working. So how do I go back and find out what exactly is causing the problem?

    Leave a comment:


  • Steve Machol
    replied
    There is no recommended and safe way to do this. All the vB database tables share info with other tables. You cannot just restorre some of them and not run into signifficant errors.

    Honestly this problem has nothing to do with the database anyway. It's either a server issue or a problem with an modification you installed.

    If you have followed all the instructions I've given so far, then the next step is to reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version and that none show 'File does not contain expected contents':

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

    Leave a comment:


  • Factory Ten
    replied
    Originally posted by Steve Machol View Post
    There is no way to start from scratch and keep your data. The two are mutually exclusive.

    Assuming you have not moddified the vB code, this is a server issue and will need to be fixed on the server level. Changing vB is not going to solve this.
    Other people run vB fine on the same server that I do. I can only conclude that at some point I made some change to my vB data that's causing this.

    What I'm hoping I can do is a MySQL dump of the users/posts and then restore it once I've "reformatted" my website. Is this possible?

    Leave a comment:


  • Steve Machol
    replied
    There is no way to start from scratch and keep your data. The two are mutually exclusive.

    Assuming you have not moddified the vB code, this is a server issue and will need to be fixed on the server level. Changing vB is not going to solve this.

    Leave a comment:


  • Factory Ten
    replied
    I tried this suggestion previously but it didn't solve anything. This time I'd like to start from scratch without losing any of my posts or users. Is there a way to do this?

    Leave a comment:


  • Steve Machol
    replied
    First, check your attachment size setting in the Admin CP and make sure it's large enough. If that is fine, then you need to change the upload size for both PHP and for MySQL. You need to have root access to the server to do this. Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X