Announcement

Collapse
No announcement yet.

Can't Add Attachments Over 32k

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Add Attachments Over 32k

    I'm running into some issues with attachments. Specifically, my site doesn't seem to want to allow any attachments above 30k in size. If a user attempts to upload something, vB just says its uploading and stays like that forever.

    I've checked in Attachment Manager and am allowing files up to 300k to be uploaded, for all image types as well as being 1024 x 1024. Furthermore I've disabled the few Products that I've imported into my system. Still, nothing.

    Any idea why this is happening?

  • #2
    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      My upload_max_filesize is 7 megs so that doesn't seem to be it. Max post size is 8 megs and my memory limit is 90 megs. Those all seem okay. Are there any other attachments settings I'm overlooking?

      Comment


      • #4
        Check the attachment permissions here:

        Admin CP -> Attachments -> Attachment Permissions
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          Check the attachment permissions here:

          Admin CP -> Attachments -> Attachment Permissions
          Negative Ghost Rider. Everything there looks fine.

          Just to make sure its not me, this is a screenshot of my Attachment Manager:

          http://img110.imageshack.us/img110/5903/picture1ld5.png

          Comment


          • #6
            Then it's either due to a plugin or there is something on your server causing this. I can't imagine what else would cause this if the permissions are set correctly.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I'll speak with my hosting provider. Thank you for your time.

              Comment


              • #8
                Just in case this helps at all, I can add the attachment if its hosted on another website. Just not upload it from my Mac. Hmm...

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X