Announcement

Collapse
No announcement yet.

Sudden error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sudden error

    I have recieved on my email an error from my vbulletin

    Database error in vBulletin :

    mysqli_real_connect() [<a href='function.mysqli-real-connect'>function.mysqli-real-connect</a>]: (08004/1040): Too many connections
    /home/fileclus/public_html/forum/includes/class_core.php on line 1040

    MySQL Error :
    Error Number :
    Date : Sunday, August 26th 2007 @ 10:06:55 PM
    Script : http://forum.filecluster.com/mobile-...1-post102.html
    Referrer :
    IP Address : 66.249.66.36
    Username :
    Classname : vB_Database_MySQLi
    The link works just fine,tho I don't understand the error.Then another error appeared in my email

    Database error in vBulletin :

    mysqli_real_connect() [<a href='function.mysqli-real-connect'>function.mysqli-real-connect</a>]: (08004/1040): Too many connections
    /home/fileclus/public_html/forum/includes/class_core.php on line 1040

    MySQL Error :
    Error Number :
    Date : Sunday, August 26th 2007 @ 10:10:53 PM
    Script : http://forum.filecluster.com/showthread.php?t=56
    Referrer :
    IP Address : 66.249.66.36
    Username :
    Classname : vB_Database_MySQLi

    I dont get it...both links work
    SWTOR Forums | Software Forums

  • #2
    The server has maxed out the number of MySQL connections it allows. This is a server-wide limit, not just your forums. You can try turning persistent connections off in your config.php:

    $config['MasterServer']['usepconnect'] = 0;

    But if you still have problems after that, all you can do is ask your host to raise the maximum number of connections they allow.

    Here is more info on that error:

    http://dev.mysql.com/doc/refman/5.0/...nnections.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      it seems that $config['MasterServer']['usepconnect'] = 0; is off by default in config.php

      also,my board has several users so no traffic...and i am on a dedicated server with 1 more site,which doesn't have so much traffic.

      i rly don't know if this is of any importance, but i've set my dbtype at the install to msqli . i do have php5 and mysql4 but i don't know if it's the right option,so any feedback is appreciated. i will try to set the max connections higher,tho i doubt it it's from there.
      SWTOR Forums | Software Forums

      Comment


      • #4
        also the mysql and mysqli max links and connect is set to unlimited
        SWTOR Forums | Software Forums

        Comment


        • #5
          I keep getting the same error as the posted. Got 670 members on the site but the errors happen mostly at night. Any other information in this. It just recently started happening.

          SVT

          Comment


          • #6
            Originally posted by vexxy View Post
            it seems that $config['MasterServer']['usepconnect'] = 0; is off by default in config.php

            also,my board has several users so no traffic...and i am on a dedicated server with 1 more site,which doesn't have so much traffic.
            As I said it's a server-wide limit - not just your forums. Again:

            http://dev.mysql.com/doc/refman/5.0/...nnections.html
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Originally posted by Steve Machol View Post
              As I said it's a server-wide limit - not just your forums. Again:

              http://dev.mysql.com/doc/refman/5.0/...nnections.html
              as i said in my previous post...the max connections is set to unlimited in my server config...tnx anyway
              SWTOR Forums | Software Forums

              Comment


              • #8
                The error is pretty clear. Just check the MySQL site. I am not aware of any way to set this to 'unlimited' so that is most likely the problem right there.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I got the exact same error today, for the first time. It turned out that my host was playing around with limitations for both max_connections in mysql and mail sending limitations. It's either your host, or a flood. Contact your webhost to block the IP's specified in the e-mail, but first check them so that they don't belong to any of your usual members and spiders (ex Googlebot or Yahoo!Slurp).
                  To view the maximum connections allowed by mysql, go to you admincp->Maintenance->Diagnostics->System Information(MySQL Variables)->Submit. Check the value of max_connections.
                  Last edited by Delioncourt; Fri 31 Aug '07, 8:18am.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X