Announcement

Collapse
No announcement yet.

MySQL error: table session is full

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL error: table session is full

    MySQL Error is

    Database error in vBulletin 3.6.7:

    Invalid SQL:

    INSERT IGNORE INTO session
    (sessionhash, userid, host, idhash, lastactivity, location, styleid, languageid, loggedin, inforum, inthread, incalendar, badlocation, useragent, bypass, profileupdate)
    VALUES
    ('e419a7203e2eecc988633014538a73a1', 0, '125.235.44.206', '2c7fd75564e7d2c92ea4fae0786eaf12', 1187666130, '/forum/forumdisplay.html?f=18', 0, 0, 0, 18, 0, 0, 0, 'Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Seekmo 10.0.314.0)', 0, 0);

    MySQL Error : The table 'session' is full
    Error Number : 1114
    Date : Tuesday, August 21st 2007 @ 07:15:30 AM
    Script : removed
    Referrer : removed
    IP Address : 125.235.44.206
    Username : Unregistered
    Classname : vB_Database

    I've just got 40 emails of this error sent directly to me. I went checking the session table, it only had ~32k rows. I emptied the table and the error stopped happening.

    It is my surprise that the table can only handle 32k rows. I would like to have some suggestions on what happened.

    Thank you.

  • #2
    Run this query:

    DELETE FROM session;

    Then revert your footer template. You made a change somewhere that stopped the Scheduled Tasks from running and clearing out this table on a regular basis.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I did empty the table to fix that. I also checked the footer template, the cron job I know is run via $cronimage variable and it's there.

      Comment


      • #4
        Then you have made another change somewhere that is keeping the scheduled task from running that empties that table once per hour. It could be an add-on or some scripting added to another template.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by deathemperor View Post
          I did empty the table to fix that. I also checked the footer template, the cron job I know is run via $cronimage variable and it's there.
          Make sure that your cron table is still intact and doesn't need to be repaired.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X