Announcement

Collapse
No announcement yet.

db eror on usergroup management

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • db eror on usergroup management

    when I try to save the changes I make to usergroups I face this db eror:

    Database error in vBulletin 3.6.8:
    Code:
    Invalid SQL:
    SELECT * FROM forumpermission;
    
    MySQL Error  : Table 'XXXXX.forumpermission' doesn't exist
    Error Number : 1146
    Date         : Monday, August 20th 2007 @ 09:51:17 AM
    Script       : http://XXXXX/forum/admincp/usergroup.php?do=update
    Referrer     : http://XXXXX/forum/admincp/usergroup.php?do=edit&usergroupid=6
    IP Address   : **.1**.1**.213
    Username     : kaambiz
    Classname    : vB_Database
    I tried upgrading repairing etc but non of them could solve this.
    what can i do?

    thanx.

  • #2
    Can you access the database using phpmyadmin or the like? It looks like the database has become corrupt or broken.
    Toddler from Hell

    Comment


    • #3
      Originally posted by Fusion View Post
      Can you access the database using phpmyadmin or the like? It looks like the database has become corrupt or broken.
      yes I do.
      I was thinking of installing a new vb and importing needed tables from this one.

      Comment


      • #4
        So you can see the table in phpmyadmin? Try doing a check on it.
        Toddler from Hell

        Comment


        • #5
          Originally posted by Fusion View Post
          So you can see the table in phpmyadmin? Try doing a check on it.
          holly cr**!
          the table doesn't exist! :|
          what can I do now?

          Comment


          • #6
            Ehh.. Restore a backup?
            Toddler from Hell

            Comment


            • #7
              Originally posted by Fusion View Post
              Ehh.. Restore a backup?
              unfortunatley the latest available backup doesn't have it either!
              actually it is not my own board and I lately own it!

              Comment


              • #8
                Are you running any mods which may be interfering with the tables?
                Toddler from Hell

                Comment


                • #9
                  let me try disabling hook system.

                  Comment


                  • #10
                    I don't know what version your backup is for, but I'm guessing the forumpermission table has been around for quite a while, which means you're really unlucky if you only have one backup.
                    I suppose you could try to re-create the table (look at the install-scripts) but unless you find the culprit it'll just happen again.
                    Re-creating the table obviously means resetting the permissions.
                    Toddler from Hell

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X