Announcement

Collapse
No announcement yet.

Database Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Error

    Hi there i recently acquired this database error does anyone know how i can fix it?

    Database error in vBulletin 3.6.8:
    Invalid SQL:
    select count(*) as newposts from post where dateline >= 02:18 PM, 08-09-2007 and visible = 1;
    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ':18 PM, 08-09-2007 and visible = 1' at line 1
    Error Number : 1064
    Date : Thursday, August 9th 2007 @ 06:04:14 PM
    Script : http://www.vmk-sorcerers.com/forums/index.php
    Referrer : http://www.vmk-sorcerers.com/
    IP Address : 70.141.210.87
    Username : REDTAZ
    Classname : vb_database

  • #2
    The script shouldn't be pulling new posts like that. Did you add a plugin that is supposed to add this? Disable that plugin and contact the author of it for a fix.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      Originally posted by Wayne Luke View Post
      The script shouldn't be pulling new posts like that. Did you add a plugin that is supposed to add this? Disable that plugin and contact the author of it for a fix.
      Nope i havnt added any new plugin's.

      Comment


      • #4
        First, re-upload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

        Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

        [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

        If that didn't solve the problem, disable all plugins.

        Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

        define('DISABLE_HOOKS', true);

        Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Now check again.

        Do you still have the same problem?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          OK I figured out what it was thanks for the help.

          Comment

          Loading...
          Working...
          X