No announcement yet.

You have an error in your SQL syntax

  • Filter
  • Time
  • Show
Clear All
new posts

  • Wayne Luke
    Means you have an invalid SQL query.

    First, re-upload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    If that didn't solve the problem, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Now check again.

    Do you still have the same problem?

    Leave a comment:

  • bela-meaad
    started a topic You have an error in your SQL syntax

    You have an error in your SQL syntax

    Invalid SQL:

    SELECT email, username
    FROM user
    WHERE userid IN ();

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 3
    Error Number : 1064
    Date : Tuesday, July 31st 2007 @ 09:18:36 AM
    Script :
    Referrer :
    IP Address : **********
    Username : macd
    Classname : vb_database
    what does that mean

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.