Announcement

Collapse
No announcement yet.

forum searching

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • forum searching

    On my board I noticed that when doing an Advanced Search in a forum (that I know has a thread with two posts that have the same word in it) that only one of the posts display in the search results when I use that word as as the search keyword.


    Any idea why that would be?

    Do posts/threads only get indexed every so often?

  • #2
    Do you search through thread titles, or through entire posts?
    I believe they get indexed directly when the post is created. If you use the vBulletin search engine. Try changing your search type to FULLTEXT.

    Comment


    • #3
      I searched through entire posts.

      Where is the setting for FULLTEXT ?

      Here's what I have discovered since I last posted: The keyword I was using was "automobile" BUT the word, in the post, was actually "automobiles." Is that the way the search is supposed to work?

      Comment


      • #4
        Yes, with fulltext on you use the database fulltext with option for boolean search, instead of the build in vbulletin search engine.

        Admin Control Panel > vBulletin Options > Search Type

        Comment


        • #5
          Does the FULLTEXT search use more server resources?


          with fulltext on you use the database fulltext with option for boolean search,
          Do you mean there is a setting to allow boolean search with FULLTEXT search or that the end-user can use boolean search methods?
          Last edited by rnmcd; Sat 7 Jul '07, 3:01pm.

          Comment


          • #6
            Here is our documentation about the search types.

            http://www.vbulletin.com/docs/html/search_type

            Comment

            Loading...
            Working...
            X