Announcement

Collapse
No announcement yet.

Random site crash MYSQL Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Random site crash MYSQL Error

    My site randomly crashed tonight, with the attached error. It appears it's trying to send a very large sql command each time you try to visit the index. The post pages work, just not the index or admincp. Please see the error at the following link.

    Please help!

    Thanks!

    http://www.trypants.com/error.txt

  • #2
    How many forums approx~ have you set up on your board? 15? 150? 500? more?

    Also, check with your hosting provider to see what the errors reported in the mysql log file are. What's the reason Mysql drops out.

    which version of vB do you run, and do you have any plugins installed?

    Comment


    • #3
      43 root/sub forums, all plugins are disabled, vbulletin 3.6.4.

      I'm waiting on the host to get back to me for the logs
      Last edited by bkbelew; Sun 1 Jul '07, 6:54am.

      Comment


      • #4
        I fixed it temporarily by commenting out the following line in index.php.

        build_datastore('maxloggedin', serialize($vbulletin->maxloggedin), 1);

        Comment


        • #5
          You are trying to write a ~900Kb string for maxloggedin to the datastore???? A normal installation should contain an array of 2 items with a total string length under 100 bytes.

          Please remove the modification casuing this.
          Want to take your board beyond the standard vBulletin features?
          Visit the official Member to Member support site for vBulletin Modifications: www.vbulletin.org

          Comment


          • #6
            There have been no modifications installed in probably 4 months, all of which are disabled currently. It is still trying to write that command.

            Comment


            • #7
              That's because disabling whatever mod has done this has will not actually fix the corrupted datastore, you need to run a bit of sql as well ;

              Code:
              REPLACE INTO datastore (title,data,unserialize) 
              VALUES ('maxloggedin','',1)
              This is the second time I've seen this in a couple of weeks - what mods do you have installed ?
              Baby, I was born this way

              Comment


              • #8
                Thanks, that fixed it.

                Plugins are in my attachment
                Attached Files

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X