Announcement

Collapse
No announcement yet.

Bug? vBulletin is mixing secure/unsecure content...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bug? vBulletin is mixing secure/unsecure content...

    Now that I've moved my entire site (and all graphics included in it) to a secure https: SSL server with certs set up, people are getting constant warnings in threads about mixed content asking if they want to view the unsecure items too in a popup that shows up on any thread page.

    Found the culprit:

    <img src="http://mystatus.skype.com/smallicon/....">

    Is this only because vB is trying to show people's Skype status by embedding items directly from other sites in mine that turn out to not be secure?

    Is there any way to host all page elements locally? I don't want the server waiting on other servers before declaring a page fully loaded. Do I just need to turn off show skype status somewhere?

    Could there be any other non-local page elements being included?

  • #2
    Under vBulletin Options -> Style & Language Settings, set "Use Skypeweb Image" to no.

    However, any image included in a post with the [img] tag will trigger the same warning unless you offer someplace for users to upload images to your site.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      That fixed it! Thanks.

      I remember seeing that new Skype setting after my last upgrade, and perhaps a quick note right below that option in the paragraph description to the effect that enabling this will break SSL-encrypted sites.

      I have [img] tags disabled---so they see only links---always have. Prefer attachment option to avoid possibility of broken links in user posts. So guess I lucked out there in a way... hehehe.

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X