Announcement

Collapse
No announcement yet.

problem uploading attachments...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    As I said you need to ask your host to do this.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #17
      Ok steve, i ask to my host and this is the answer!

      Matias,

      All of the above is possible on your (dv) Dedicated Virtual. You have full root access to all of your files and directories, which allows you to chmod any file or directory. Are you sure safe_mode is disabled locally? If you continue to have problems please provide your Plesk login information so that we may further investigate.

      If you have any further questions regarding your services, please feel free to contact us at any time.


      Best Regards,
      As i said, i still can upload files, but my users can't...
      i and my users can upload pictures to photoplog gallery, i know is not a part of vbulletin but i assume use the same way to upload files...

      Any other way to fix this?

      Comment


      • #18
        No sorry. The only way I know of to fix this is what I've already posted. And it's obvious you do not have access to the server's root /tmp directory.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #19
          /tmp its chmod'd 1777

          i dont really understand

          check this screen, i've access to all...
          Attached Files

          Comment


          • #20
            Then there is another problem - either a modification you made or some other server issue. However if you are still getting this:

            Upload of file failed.

            Then I am 99% sure this is a server issue. The next step in troubleshooting this is that you or your host will need to check the server logs to find out why this upload failed. The info should be there.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #21


              I as administrator can upload files without any problem, but users can't.
              if i am able to upload files (as admin), doesn't it mean that the server is working fine?

              i can't solve this yet and it's a big problem!!!!!

              Comment


              • #22
                How are you currently saving your attachments?

                Comment


                • #23
                  im saving on file system... .../forum/files/

                  yesterday i moved a user from users group into the admnistrator group...
                  now this user can upload files but the system cant create the folder...

                  "unable to create folder for your file" or something like that...

                  Comment


                  • #24
                    Then the issue is that your attachments folders are not all chmoded correctly

                    you can run the following command inside of the vBulletin attachments folder.

                    chmod 777 -R *


                    This will recusively change all of the permissions for all files and folders, and should allow your users to upload files.

                    Comment


                    • #25
                      ok zachery you make my day happy!

                      i dont do what you said but i find the problem, thank to you!

                      3 months ago we move from one server to other one... so i download all the files and upload to the new server...
                      all files change the owner, and apache cant write there...
                      i change the chown to the files/* folder... and now its workin fine!

                      there is the issue...
                      thx for the cooperation to all

                      close*

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X