Announcement

Collapse
No announcement yet.

problem uploading attachments...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem uploading attachments...

    Hi, my users has problems uploading attachments
    i can upload files without problems but my users not.

    im running the diagnostic and said this:

    file_uploads: On
    open_basedir: /var/www/vhosts/xxx.com/httpdocs:/tmp
    safe_mode: On
    upload_tmp_dir: /tmp
    upload_max_filesize: 10.00 MB

    Results: No errors occurred while opening the uploaded file for reading. You should be able to turn off the "Upload In Safe Mode?" option without any adverse effects.

    I turned off and on safe_mode but nothing...

    phpinfo is public on
    http://www.banite.com.ar/foro/forum.php?do=phpinfo

    i did a search but any answer solve my problem

    thx in advance...

  • #2
    What specific problems are your users reporting when trying to upload attachments? Are they in a usergroup that has permission to upload attachments (Usergroup-> Usergroup Manager)? Do they have permissions to upload the extensions they are attempting (Attachments -> Attachment Manager)?
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      every group have permission to upload files without size limit and without disk space limit... all the extensions are enabled...

      the error was:

      Error
      leomattioli1.jpg:
      Upload of file failed.

      Comment


      • #4
        You have open_basedir set for your local directory. You will need to turn that off or create a temp directory within your httpdocs directory and set that in your Admin CP under vBulletin Options -> Server Settings and Optimization Options. Make sure the new temp directory is chmod 1777 as well.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          ok, i have a folder under httpdocs called tmp (777) but users still cant upload files, same error...

          on Server Settings and Optimization Options, tmp dir is: /var/www/vhosts/xxx.com/httpdocs/tmp

          safemode turned on...

          Comment


          • #6
            how can i turn out the open_basedir, in my php.ini its commented... so i think there is on other place... for example vhost/php.ini but i dont know... :S

            Comment


            • #7
              i switch safe_mode to Off, but still the users have problems uploading files

              Comment


              • #8
                It could be specified in an .htaccess file, your apache config files or another php.ini file. You would need to contact the hosting provider.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud demonstration site.
                vBulletin 5 API - Full / Mobile
                Vote for your favorite feature requests and the bugs you want to see fixed.

                Comment


                • #9
                  i have full root access, its a vps...

                  but, im using photoplog gallery and all the users can upload images to the gallery, using http upload...

                  im turned off safe_mode but attachments dont work

                  Comment


                  • #10
                    Either your open_basedir setting is wrong or the directory is not chmod'd to 777, or you do not have a /tmp directory on this server that is chmod'd to 777.

                    I do not believe that latter is available to you on a VPS. You will have to ask your host to check this.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      i can upload anythin, images, videos, etc with other script...
                      i think its misconfiguration on some part of vbulletin, i dunno...

                      ok, start over...

                      i have:

                      safe_mode = off...
                      so, i dont need a tmp folder...
                      true of false?

                      on Server Settings and Optimization Options i have turned off Safe mode...
                      so, i dont need fill the input bellow, right?

                      anythin else?

                      i, as administrator can upload attachments, but my users cant...

                      Comment


                      • #12
                        Originally posted by elmati View Post
                        safe_mode = off...
                        so, i dont need a tmp folder...
                        true of false?
                        False. You always need a tmp folder. Its where PHP puts the file before vBulletin either stores it in the database or the file system.

                        Can you upload files within a post or only through the diagnostic. The diagnostic doesn't actually store the file. It just sees if it can if permissions were correct.

                        It could be a configuration of vBulletin but you're not really giving us any information about the configuration itself. I suggest opening a support ticket with full Admin CP (w/ English Language), FTP and phpMyAdmin permissions.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API - Full / Mobile
                        Vote for your favorite feature requests and the bugs you want to see fixed.

                        Comment


                        • #13
                          hi, wayne

                          i can upload files within a post, as an admin...
                          but users and moderators cant...

                          and i and all the users can upload files to photoplog gallery...

                          i cant find the problem

                          Comment


                          • #14
                            You need to follow my and Wayne's instructions to fix this.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Originally posted by Steve Machol View Post
                              Either your open_basedir setting is wrong or the directory is not chmod'd to 777, or you do not have a /tmp directory on this server that is chmod'd to 777.

                              I do not believe that latter is available to you on a VPS. You will have to ask your host to check this.
                              i dont know how turn off open_basedir...

                              now my safe_mode its turned off...
                              id created an empty chmod 777 folder called "tmp" within httpdocs...
                              in my php.ini open_basedir its commented, i assume its off...
                              i can upload files but my users cant...

                              So, i dont know how to fix this issue...

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X