Announcement

Collapse
No announcement yet.

vBulletin can't write even after CHMOD 777?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vBulletin can't write even after CHMOD 777?

    Hi, I've just moved to a FreeBSD server and the forums are working just fine in every regard except that attachments won't seem to display or work at all.

    The vB control panel still shows my old server acct name in the path:

    /home/{oldserveracctname}/zorg/attachments

    And I'm using the Attachment Storage Type action: Move Items to a Different Directory.

    When I enter:

    /home/{newserveracctname}/zorg/attachments

    I get this error:

    We attempted to write a test file to /home/******/zorg/attachments, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.We attempted to write a test file to /home/zaonorg/zorg/attachments, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.

    (with my actual acct name instead of **** of course).

    I've CHMOD'd both the zorg and the attachments folders to 0777, and I've set it to apply to all items inside those folders as well as those folders themselves.

    My server support persons are asking/stating:

    I've checked and the permissions should now be set; if you have any more
    problems, please see if there is a specific PHP error that is generated so we can troubleshoot further

    The folder has complete deletion privileges; can you give me more details on the specific PHP error, or is it capturing errors?

    Are you sure vBulletin doesn't have a temporary location it uploads to before uploading the attachments? Have you tried moving the attachments directory inside the web root?


    Any suggestions on how I can fix this? Or am I going about changing vB's folder destination the wrong way?

    Thanks in advance for any insight.. I have my site still down while trying to troubleshoot this so we don't end up with attachment problems later when things are working and my forum members are starting to complain since we're into our 4th day of troubleshooting

    --Justin

  • #2
    I have heard that some systems require chmod 1777 for file attachments to work properly.
    Translations provided by Google.

    Wayne Luke
    The Rabid Badger - a vBulletin Cloud demonstration site.
    vBulletin 5 API - Full / Mobile
    Vote for your favorite feature requests and the bugs you want to see fixed.

    Comment


    • #3
      My secure FTP software only lets me do 3 digits (777), so had my host do it for me to 1777, but still get same error. Any other suggestions as to why PHP can't write to a 0777 or 1777 folder?

      Comment


      • #4
        Make sure that the folder and all the files belong to the same UID as Apache (or whatever process is running PHP).
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          The host said this:

          > Try it now, it was set to {acctname} instead of nobody.

          And now it works great!

          Thanks, guys!

          Comment

          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
          Working...
          X