Announcement

Collapse
No announcement yet.

Problem uploading attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem uploading attachments

    I have a problem with not being able to upload any files from the message posting by using manage attachments.
    I have made sure the file was with the required sizes and it keeps coming back as file failed to upload.
    This worked fine until my latest update to PL1, any ideas?

  • #2
    What happens when you try the Upload diagnostics?

    Admin CP -> Maintenance -> Diagnostics -> Upload

    Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I tried to upload through this and it failed also I have copied and pasted the results bleow.



      Help
      Pertinent PHP Settings file_uploads:Onopen_basedir:Nonesafe_mode:Offupload_tmp_dir:Noneupload_max_filesize:2.00 MB
      Help
      Results No file uploaded and no local file found. The test cannot continue.


      http://www.packing4life.com

      I have enabled the phpinfo

      Comment


      • #4
        This error is because your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 1777.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          in the manage attachments upload I get this error

          Upload Errors p22feedramp.jpg:
          Upload of file failed.

          Comment


          • #6
            Please see post #4 for the fix to this.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Steve thanks for you quick response I have contacted my web host to take care of this, Dave.

              Comment


              • #8
                Steve

                Same problem. Have contacted my host. Does the directory need to be created by me within my hosting space or is it a system directory elsewhere ?

                Thanks,

                Dave

                Comment


                • #9
                  In answer to my own query it should be in the root of my hosting space. The 'upload_tmp_dir' setting was configurable using the control panel my ISP provides. They also suggested setting 'sessions_save_path' to the same "tmp" directory.

                  Hope this helps someone.

                  Dave

                  Comment


                  • #10
                    Originally posted by davesh View Post
                    In answer to my own query it should be in the root of my hosting space. The 'upload_tmp_dir' setting was configurable using the control panel my ISP provides. They also suggested setting 'sessions_save_path' to the same "tmp" directory.

                    Hope this helps someone.

                    Dave
                    im kinda lost here, might you expand a little more on this? on the whole thing lol, i guess my terminology is not that great and im lost! is 'upload_tmp_dir' the same as 'tmp' folder?
                    Thanks

                    Comment


                    • #11
                      I'm no authority on this stuff but I'll do my best. The "upload_tmp_dir" is a system variable used by PHP ( the scripting engine that powers VBulletin ) and tells it where to temporarily store files ( such as files/attachments in the process of being uploaded to VBulletin ). It appears some ISPs leave this value undefined. You need to create a directory called "tmp" in the root of your hosting space and change its permissions to 777 ( using chmod or your FTP program ). Your ISP then needs to add or amend the PHP.INI file which defines the system variables to point "upload_tmp_dir" to the tmp directory you have just created. The webserver software may also need to be restarted in order for the change to be effective.

                      In my case I was able to edit the value of "upload_tmp_dir" myself as it was configurable through the control panel my ISP provides me to manage my domain.

                      Hope this is clear ( and correct )

                      Dave

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X