Announcement

Collapse
No announcement yet.

WYSIWYG editor truncates content

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • WYSIWYG editor truncates content

    In the WYSIWYG-editor of vB 3.6.4 in IE7 on XP, when I type a line with a hyperlink between double quotes:

    abcdefghij "test"

    it's truncated on Save to:

    abcdefghij "

    The hyperlinked text and the final quote disappeared

    This started happening last week or so, while I haven't changed anything to my vB software or configuration in months. Could this be caused by an update of IE or something like that
    Last edited by renep; Wed 13th Jun '07, 8:41am.
    "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
    - Edsger Dijkstra

  • #2
    To troubleshoot this, first reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I have been told this is a bug in Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=422567

      Is that what you are running?
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Yes, I am using Debian Etch and I'm indeed using the affected version of the PHP package. It seems I'll have to fix this in Debian's PHP. Thank you very much Steve.
        "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
        - Edsger Dijkstra

        Comment


        • #5
          For the record, the problem was introduced in Debian Etch package php5-etch3 and is fixed in php5-etch5, which is not released yet.

          I installed the 'preview' by temporarily adding this to /etc/apt/sources.list:

          Code:
          deb http://ftp.debian.org/debian/ etch-proposed-updates main
          Then I ran the usual:
          Code:
           
          aptitude update && aptitude upgrade
          This fixed the problem Use at own risk, of course.
          Last edited by renep; Wed 13th Jun '07, 11:14am.
          "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
          - Edsger Dijkstra

          Comment


          • #6
            Originally posted by renep View Post
            fixed in php5-etch5, which is not released yet.
            The problem is now fixed in the regular Debian updates. Run the usual:

            Code:
            aptitude update && aptitude upgrade
            And check the php version in vBulletin's admincp. You should see: 5.2.0-8+etch7 (or newer). The problem is fixed in this update.
            "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
            - Edsger Dijkstra

            Comment


            • #7
              This fixed it for us!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X