Announcement

Collapse
No announcement yet.

Attachment Error : PHP's open_basedir

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment Error : PHP's open_basedir

    I get the following Msg. when trying to test the upload feature in Admincp and when trying to upload a file normaly

    PHP's open_basedir setting has been set to /home/****/:/usr/lib/php:/usr/local/lib/php:/tmp. The uploaded file was stored outside of this directory and is not readable. You will need to contact your host and ask them to specify upload_tmp_dir with a directory inside /home/****/:/usr/lib/php:/usr/local/lib/php:/tmp. Note that PHP must be able to read and write to this directory.
    Thanks

  • #2
    You need to follow those instructions, specifically contacting your host about the upload_tmp_dir setting and directory.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I forgot

      This also happened while trying to upload style and language file , to go around this I put the language file in the XML dir. and imported it from there and it worked fine.

      Comment


      • #4
        Steve, Thanks
        I will , But what about the my post above

        Comment


        • #5
          Steve
          I set the upload to the safe mode and it worked very fine

          Thanks Man

          Comment


          • #6
            Please

            I can upload attachments from a remote link but can't upload them from my PC.
            I thought the problem is gone!
            Any Idea Steve?
            Thanks

            Comment


            • #7
              What happens when you try the Upload diagnostics?

              Admin CP -> Maintenance -> Diagnostics -> Upload

              Enable phpinfo in the Admin CP, then provide the URL to your forums. This may help us troubleshoot this problem.

              Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Public phpinfo() Display Enabled
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Done

                this is the Msg when trying the upload test :
                Pertinent PHP Settings
                file_uploads: On
                open_basedir: /home/alyaseer/:/usr/lib/php:/usr/local/lib/php:/tmp
                safe_mode: Off
                upload_tmp_dir: /home/vdeck/tmp
                upload_max_filesize: 2.00 MB

                Help
                Results
                PHP's open_basedir setting has been set to /home/alyaseer/:/usr/lib/php:/usr/local/lib/php:/tmp. The uploaded file was stored outside of this directory and is not readable. You will need to contact your host and ask them to specify upload_tmp_dir with a directory inside /home/alyaseer/:/usr/lib/php:/usr/local/lib/php:/tmp. Note that PHP must be able to read and write to


                Php info is enabled now.
                www.alyaseer.net

                Thanks Again Steve

                Comment


                • #9
                  With safe mode on

                  Pertinent PHP Settings
                  file_uploads: On
                  open_basedir: /home/alyaseer/:/usr/lib/php:/usr/local/lib/php:/tmp
                  safe_mode: Off ( alghouth I turned it on )
                  upload_tmp_dir: /home/vdeck/tmp
                  upload_max_filesize: 2.00 MB
                  Help
                  Results
                  The attached file could not be copied to /tmp/ddb6ffcdd24a76b24dff9c077c68b78f. PHP's safe_mode setting must be disabled for uploads to function. You will need to contact your host for this to be changed.
                  Last edited by abufaisal; Tue 12th Jun '07, 12:08pm. Reason: safe_mode: Off ( alghouth I turned it on )

                  Comment


                  • #10
                    You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your /home/alyaseer directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

                    /home/alyaseer/tmp

                    Also the /home/vdeck/tmp directory must be chmod'd to 1777.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X