Announcement

Collapse
No announcement yet.

Stop hooks..forum doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • haythamghareeb
    replied
    Through my forum's CP I did a check and found files in my forum directory (over 80) that weren't supposed to be there. Some go back to 3.6.5 version and some that didn't belong in the root folder at all. I am really amazed how they got there. I deleted all of them along with the vaispy.php and there was an (I think that' the name ) xss protection product file and now my forum is ok. Just wanted to share the info.

    Leave a comment:


  • Wayne Luke
    replied
    Originally posted by haythamghareeb View Post
    Hi,
    What modification? This happens when I disable hooks i.e. all modifications are stopped..right?
    Some mods make replacements directly into the parsed templates and call functions from there. Not a good programming practice. This was probably the cause of this.

    Leave a comment:


  • haythamghareeb
    replied
    Got it..You were right. The script causing this was called vaispy.php. It was also causing an extra load on my forum due to it being Ajax and loaded every 7 seconds. Sorry for disturbing you. I am cutting down on mods now. I am trying to run the forum like you made it to run so I don't get errors. Thanks.

    Leave a comment:


  • Marco van Herwaarden
    replied
    This function gets called even when the plugin system is turned off it seems. Please contact the author for a solution.

    Leave a comment:


  • haythamghareeb
    replied
    Originally posted by Marco van Herwaarden View Post
    Fatal error: Call to undefined function: parsehide()

    parsehide() is not a vBulletin function, please contact the author of the modification.
    Hi,
    What modification? This happens when I disable hooks i.e. all modifications are stopped..right?

    Leave a comment:


  • Marco van Herwaarden
    replied
    Fatal error: Call to undefined function: parsehide()

    parsehide() is not a vBulletin function, please contact the author of the modification.

    Leave a comment:


  • haythamghareeb
    replied
    They say a pic is worth a 1000 or is it a 100 words. By the way, thanks for caring. See the attached pic.
    Attached Files

    Leave a comment:


  • Floris
    replied
    When you are in the admincp in the top frame does it say:

    You are currently running: 3.6.7 or 3.6.7pl1 ?

    Leave a comment:


  • haythamghareeb
    replied
    Thanks floris..I said I have upgraded from 367 to the latest version in my post which is 3.6.7 pl1. I believe I, do, have the latest version.

    Leave a comment:


  • Floris
    replied
    That's because the latest version is not 3.6.7, but 3.6.7pl1.

    Leave a comment:


  • haythamghareeb
    started a topic Stop hooks..forum doesn't work

    Stop hooks..forum doesn't work

    Hi,
    My forum has been acting up so I uninstalled most of my hacks. When that didn't work, I disabled the hooks system. Now whe I try to browse posts I get this message:

    Fatal error: Call to undefined function: parsehide() in /directoryname/directoryname/public_html/353/includes/functions_forumdisplay.php on line 162

    I thought when we disabled the hooks system , VB would be acting only on its natural code..??

    By the way..I have just upgraded from 367 to the latest but still get a message saying that the latest version is 367PL1.
    Any ideas?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X