Announcement

Collapse
No announcement yet.

Users logging in, getting redirected to forumhome saying they are not logged in

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Then you have another modification that has broken this function.

    First, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    [Note: In some cases you may also need to remove any of the listed .xml files in the includes/xml directory.]

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

    Leave a comment:


  • fusiongoddess
    replied
    Thanks guys, but the domain and path are already at default. "blank" and "/"

    Any other suggestions?

    Leave a comment:


  • Steve Machol
    replied
    It's the same recommendation.

    Leave a comment:


  • PcosKat
    replied
    Which fix should be used? Steve's or Floris'?

    This problem has been plaguing my site for some time now.

    Leave a comment:


  • Steve Machol
    replied
    Try this. Upload the tools.php script in the 'do_not_upload' folder of the vB zip file to your Admin CP directory and run it from your browser. Use this to reset the cookie domain and path back to the defaults. And then leave your cookie domain and path at the default settings. There is no reason to change these. If you need to specify a unique cookie, use the cookie prefix setting in config.php instead.

    Leave a comment:


  • Floris
    replied
    Get the tools.php file from the do_not_upload folder and put it in the admincp dir and run it from the browser. Reset the cookie domain and path. This should fix it.

    Leave a comment:


  • Users logging in, getting redirected to forumhome saying they are not logged in

    Lately I've had an abundance of users email for support saying that they login, the screen says Thank you for logging in...etc. and redirects them to forum home where it says they are not logged in.

    I had a few cases of this when we were using 3.6.4, and just yesterday I upgraded to 3.6.7 PL1. It seems several users are now having this problem.

    All of these users are using IE.

    I've told them all to check the Rememeber me box, they have, and in IE to go to Tools > Internet Options click Settings button under Browsing history and to make sure "Automatically" is set there. This is a fix for some people, but others write back saying that it is already set like that and they are still having problems.

    Do you think it could be a plugin or mod?? Any thoughts are appreciated. Thanks!
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X