Announcement

Collapse
No announcement yet.

Database error - invalid SQL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error - invalid SQL

    Got the following database error this evening. And this time i got it myself and not someone of my users as i previously received and posted here.

    The error was the following;

    Database error in vBulletin 3.6.7:

    Invalid SQL:

    DELETE FROM vb_userlist WHERE userid = 328 AND relationid IN (203, , 203, , 203) AND type = 'buddy';

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' 203, , 203) AND type = 'buddy'' at line 1
    Error Number : 1064
    Date : Wednesday, May 23rd 2007 @ 08:47:29 PM
    Script : http://www.wielerarchieven.be/forum/...=reallydomerge
    Referrer : http://www.wielerarchieven.be/forum/...php?do=domerge
    IP Address : xx.xx.xx.xx
    Username : Stefaan
    Classname : vB_Database_MySQLi


    Like in the previous database error i received it has something to do with the IN statement. It occurred when i merged two users. Trying to merge them again did work.

    Don't know why this error happened, but i suspect it could be caused by the import i did from my old IPB forum into vBulletin ... could that be the case? Only guessing here cause i don't know all inner workings of vBulletin (and frankly i don't need to know

    Anyway if someone from the support team wants to look into this, i'm more than happy to give the necessary details and open a support ticket.

  • #2
    SQL Syntax errors are almost always related to modified code. To troubleshoot this, the first thing you need to do is remove any hacks or plugins, then see if you still have this problem.

    If so, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server.

    Next, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks for the reply Steve. Well i only got two hacks installed but i'm 100% sure that when the previous error occurred that it was a clean install.

      I'll follow your suggestions, but i'm afraid it can take a while before i get the same error again.

      [edit]
      Seems to be related to this bug report
      [/edit]
      Last edited by WielerArchieven; Thu 24 May '07, 10:21am. Reason: link to bug

      Comment


      • #4
        Not sure how since that was fixed in 3.6.7 and that's the version you are running.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X