Announcement

Collapse
No announcement yet.

Forum is showing the wrong time

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forum is showing the wrong time

    I have a new forum 3.6.7 PL1 that shows the wrong time and I can't understand why.

    When the time here in Sweden is 17.44 the forum is showing 15.44.

    I have set the Default Time Zone Offset to GMT +1 and the Daylight Savings to yes. This is all correct.

    I changed the Long Date Format to Y-m-d H:i [O / T] and that made no change to my pages in Swedish. The english pages showed this:

    All times are GMT. The time now is 03:49 [+0200 / W. Europe Daylight Time].
    The server time seems to be correct.

    Is there something I have missed to check?

  • #2
    Check your server time. Ask the host to confirm the date/time on the server is accurate.

    Comment


    • #3
      I confirmed the time by using a simple VBScript
      Code:
      <%=now%>
      and the output is this:

      5/21/2007 7:45:11 PM
      Just found another vB-forum with the wrong time: http://www.alltomtv.se/

      Alla tider är GMT +1. Klockan är nu 18:47.
      Time is now 19.47.

      Comment


      • #4
        This was due to the timezone set in the usercp for the user view the site.
        Kerry-Anne :)

        Twitter Blog

        www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

        Comment


        • #5
          I'm was also getting wrong times with 3.6.7 ... dedicated server, and all times have been verified.

          Come to find out it was USER CP time settings.

          Comment


          • #6
            vBulletin gets its time from the server. You need to set the timezone and DST settings in the Admin CP to match the timezone of the server your forums are running on. Then each user needs to set their local timezones/DST in the User CP. If you do this correctly and the server time is correct, then the correct times will show.

            This also assumes that you have not modified the footer template to affect the DST detection code in it.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I have the same problem with a fresh install of vb 3.67PL. All my other software installations (other brands on the same dedicated server) show the time correctly. I am in the same time zone as HenrikL. For me it is also 2 hours differnece (wrong). For me as admin and for all testusers.

              It must have something to do with vb, if the time of my server is correct and all other boards are displaing it correctly.

              "You need to set the timezone and DST settings in the Admin CP to match the timezone of the server your forums are running on"

              Do you mean by this, that I have to "cheat" in ACP, so that at the end of the day the time in the time stamp of each posting is correctly displayed?

              Comment


              • #8
                No, you don' have to 'cheat'. If you do this right it does work. Please start your own thread if you have any further questions.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  Please start your own thread if you have any further questions.
                  Excuse me but this is exact the same problem like HenrikL had (starter of the thread). So a double posting might be not adviseble.

                  Look at my screenshots below. My ACP settings seem to 100% correct. As I said earlier all other software is displaing the time stamp correctly and the second screenshot of a posting I made with these ACP settings 5 minutes ago.

                  What did I then do wrong, if it is not a vb issue. How did HenrikL did the same problem get resolved?
                  Attached Files

                  Comment


                  • #10
                    Please do as I asked and start your own thread if you want further help. Thank you.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by Steve Machol View Post
                      vBulletin gets its time from the server. You need to set the timezone and DST settings in the Admin CP to match the timezone of the server your forums are running on. Then each user needs to set their local timezones/DST in the User CP. If you do this correctly and the server time is correct, then the correct times will show.

                      This also assumes that you have not modified the footer template to affect the DST detection code in it.
                      Hi Steve,
                      All settings in our forum AdminCP and UserCP have been set correctly, exactly as you've advised above, and yet the time is still show incorrectly, namely with one hour off - e.g. now it's 10:14 am GMT-5, but forum shows: "All times are GMT -5. The time now is 9:14am."

                      I'm looking at the time shown on the bottom of your forum here, and noticing that it also displays with one hour off as well - that's exactly same as the time displays in our forum. Any idea why it shows one hour off and how to fix it?
                      Thanks!

                      Comment


                      • #12
                        That is because of the DST settings on your PC.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          times get F^^cked up randomly

                          The times on my board get goofed up at random. I checked all the posts and the server time is compensated with -5 for eastern US with daylight savings time enabled. Obvioulsy a user can have their own settings and i get all that....

                          Board Stats: Most users ever online was X, Today at 01:34 PM. and its only 930am

                          As a logged in user: You last visited: 07-31-2007 at 11:33 AM. and it was 933am eastern time

                          Why cant i just make all board times to be my time zone? Forget the "all times are in GMT -/+ yadayada, the time is now X"

                          Forget GMT for the forums...it should only be relevant for offsets and daylight savings time... not a basis for time that people know nothing about (99.9% of all people have NO idea what GMT is to begin with!)

                          kiss (do the math)

                          wanted to clarify that kiss is not kiss my butt, but keep it simple stupid

                          Comment


                          • #14
                            problem solved - ADMIN profile settings fixed it

                            after going out of the forum administrator i went to the control panel for the admin as a user browsing the forums... i had to reset the timezone. I guess it isnt set when you set it up as an administrator and define all that stuff... anyway... just a nuisance, its fixed (GMT does suck though... it really never needs to be presented to a user... they think its a car) <snicker>

                            Originally posted by DRIVE View Post
                            The times on my board get goofed up at random. I checked all the posts and the server time is compensated with -5 for eastern US with daylight savings time enabled. Obvioulsy a user can have their own settings and i get all that....

                            Board Stats: Most users ever online was X, Today at 01:34 PM. and its only 930am

                            As a logged in user: You last visited: 07-31-2007 at 11:33 AM. and it was 933am eastern time

                            Why cant i just make all board times to be my time zone? Forget the "all times are in GMT -/+ yadayada, the time is now X"

                            Forget GMT for the forums...it should only be relevant for offsets and daylight savings time... not a basis for time that people know nothing about (99.9% of all people have NO idea what GMT is to begin with!)

                            kiss (do the math)

                            wanted to clarify that kiss is not kiss my butt, but keep it simple stupid

                            Comment


                            • #15
                              Forum is showing the wrong time

                              Originally posted by Steve Machol View Post
                              That is because of the DST settings on your PC.
                              What do you mean Steve? - the DST setting on my PC is correct and it shows a correct time on my PC clock.

                              Our server is located in GMT-7:00 time zone, and we've set the time zone and DST settings in the Admin CP to match the time zone of the server our forums are running on as you've advised in this forum.

                              And yet the time shown in our forum is still one hour off, and so I don't think the problem is because the DST setting on my PC. Can you think of any other reason that causes VB forum with 'one hour' off (earlier) time?

                              Thanks,

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X