No announcement yet.

SMTP Problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • SMTP Problems

    I am trying to set up SMTP as my host has changed to allowing emails only to be sent through SMTP.

    Through my host I got all the right settings I need but everytime I run a diagnostic I get the following error.

    The mailing function returned an error while trying to send the mail.

    The following errors were outputted by PHP when attempting to send mail:

    Warning: Unexpected response from SMTP server during TO address transmission in /includes/class_mail.php on line 581
    How can I get rid of this error. I filled the SMTP Host Name, port and secure connection to no. I tried the other way will all used and up to date information and I got 3 errors instead of the one.

    Any help in resolving this would be appreciated.

    EDIT: I accidentally posted this in 3.5, I actually run 3.6.5.

  • #2
    Another customer with the same error added this line to the config.php file to resolve this:


    make sure to adjust the address.
    Best Regards
    Colin Frei

    Please don't contact me per PM.


    • #3
      I just tried that, but it is still happening.
      Anymore suggestions that could solve this problem?


      • #4
        I'm afraid you'll need to contact your host in this case.
        Best Regards
        Colin Frei

        Please don't contact me per PM.


        • #5
          Enable SMTP Confirmation emails.. IIS6? php.ini? Help!

          Are we supposed to enable anything special in order for VBULLETIN to send confirmation emails via SMTP?

          Perhaps something in my php.ini?

          Or something in IIS6 for that matter?

          Maybe my host blocks SMTP? if so , what work arounds are there?



          • #6
            If your SMTP settings are correct then you need to follow Colin's advice. If you have any other questions about this, please start a new thread. Thanks.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography

            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            • #7
              this config line solved my problem for using google smtp server... fyi to anyone having problems


              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.