Announcement

Collapse
No announcement yet.

Daylight saving time doesn't update

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Originally posted by Tomzl View Post
    How do I make the "DST corrections always on" the default value for all new users?
    This already is the default for new users and the only way to change this is by editing the code.

    Originally posted by Tomzl View Post
    This second set of queries probably changes the value "Is DST currently in effect" to either yes or no for all users. Am I correct?

    DST On/Off
    On: UPDATE user SET options=options + 128 WHERE NOT(options & 128)
    Off: UPDATE user SET options=options - 128 WHERE options & 128
    There are three DST options:

    Auotmaticaly Detect DST
    DST alway On
    DST Always Off

    The above queries turn it On or Off. The previous Query sets Auto Detect.

    Leave a comment:


  • Tomzl
    replied
    Great link, added it to my favorites.

    Can you please explain these queries below?

    I assume the first one sets "Automatically detect DST settings" and the second one "DST corrections always off". What query do I need to run to set "DST corrections always on"? Also, this will probably only apply to already registered users. How do I make the "DST corrections always on" the default value for all new users?

    DST Auto-Correct
    On: UPDATE user SET options=options + 64 WHERE NOT(options & 64)
    Off: UPDATE user SET options=options - 64 WHERE options & 64

    This second set of queries probably changes the value "Is DST currently in effect" to either yes or no for all users. Am I correct?

    DST On/Off
    On: UPDATE user SET options=options + 128 WHERE NOT(options & 128)
    Off: UPDATE user SET options=options - 128 WHERE options & 128

    Leave a comment:


  • Steve Machol
    replied
    Please see this page for that and other queires:

    http://www.vbulletin.com/forum/showthread.php?t=213135

    Leave a comment:


  • Tomzl
    replied
    My computer automatically changed the time but some users are reporting problems.

    How can I set the DST settings from "Automatic" to "Always On". There is no way to set this value as default value for new users. Is there a problem with this feature or why is it not available as an option? I read through some older topics and the vBulletin team have never answered how to change the default value of this feature.

    My users are complaining about the time being wrong. When I look at their profile in AdminCP, it says "Is DST currently in effect" is "No". Obviously the automatic setting is not doing its job.

    Please, can you just answer me what query do I need to run to change the setting "Is DST currently in effect" to "Yes" or better yet make the DST changes "Always On" for all users?
    Last edited by Tomzl; Mon 26 Mar '07, 12:57pm.

    Leave a comment:


  • Wayne Luke
    replied
    There is no popup in 3.6.x, it just redirects and updates the time. When it is done, it redirects you back.

    Did your computer automatically adjust for DST and is it set to adjust for DST? In Windows you should be able to double-click the clock in the system tray and click on the Time Zone tab to check this.

    Leave a comment:


  • Tomzl
    replied
    I did modify the footer template but I didn't touch the DST code. I just added two very simple tables (one row, one cell) so that shouldn't have an effect on the DST settings.

    I remember that on older versions of vBulletin I got a pop-up notification that DST settings are in effect. Has this been removed for 3.6.5?

    Leave a comment:


  • Steve Machol
    replied
    The DST code is in the footer template. If you modified this template then that could account for this.

    Also is the time off or the GMT or both?

    Leave a comment:


  • Tomzl
    replied
    I ran the diagnostics process and vBulletin found 3 files.

    404.php
    not_found.html
    lastposts.php

    The first two are from vBulletin's impex creator Jerry and the last one is a file I use to disaplay the latest topics. None of these should have any effect on the DST settings.

    I am not using any hooks or plugins. The only thing I changed are some of the templates but only to change the look, the functionality has stayed the same.

    Is it possible to set the DST default value from "Automatically" to "Always on"? Which SQL query is needed to change this for all the registered members?

    Leave a comment:


  • peterska2
    replied
    This does not happen with a default vBulletin installation and so is something linked to a customization that you have made of your site.

    To troubleshoot this, reupload all the original vB non-image files (except install.php). Make sure you upload these in ASCII format and overwrite the ones on the server. Also be sure to upload the admincp files to whichever directory you have set in your config.php file. Then run 'Suspect File Versions' in Diagnostics to make sure you have all the original files for your version:

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Next, disable all plugins.

    Note: To temporarily disable the plugin system, edit config.php and add this line right under <?php

    define('DISABLE_HOOKS', true);

    Then if you still have this problem, create a new style and choose no parent style. This will force it to use the default templates. Finally empty your browser cache, close all browser windows then try again. Make sure you change to the new style and view your forums with it. Do you have the same problem?

    Leave a comment:


  • Tomzl
    started a topic Daylight saving time doesn't update

    Daylight saving time doesn't update

    I'm having big problems trying to display the correct time for my users. I have set the time zone for all to GMT+1. Since today one hour should be added to the GMT+1 zone because DST is in effect.

    As a test I created a new user. By default the value "Automatically detect DST settings" is selected for all new users. Despite this the time displayed for the new user did not account for the DST. In effect the time should show GMT+2 but it was still showing GMT+1.

    I started a new thread with this test user account and vBulletin did not correct the time. I logged out and logged in again and still the automatic DST change did not work. After I clicked on the User CP link in the navbar the time corrected itself. Obviously the automatic detection script is not working properly but somehow clicking on User CP link triggers it?

    How can I change the DST detect settings to "DST corrections always On" for all the users (already registered and those who will register in the future)?

    What do I have to do so that all my users will have the correct time displayed on the forum? Having them all go to User CP to have correct time displayed is not acceptable.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X