Announcement

Collapse
No announcement yet.

Fatal Error: Allowed Memory Size Exhausted Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal Error: Allowed Memory Size Exhausted Error

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 1024 bytes) in xxx/forum/includes/functions_search.php on line 219
    I had a member complain about this error two weeks ago, but since I couldn't duplicate it, I wasn't able to resolve it.


    I received the following error when trying to post a thread today. The message suggested that maybe my PHP memory limit is too small but three things perplexed me.

    First it crashed on a function in search.php so I'm curious why its using it when trying to post.



    Second, the forum wasn't real busy (55 members and 400 guests) and I have had lots more on the forum posting without incident.


    Finally, and this doesn't make a lot of sense to me. It appears to happen when the length of the subject is too long. (Such as when the characters start to scroll in the subject box)

    FYI: MySQL Packet Size 1,023.0 KB

    Help would be truly appreciated!

  • #2
    Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' varible in php.ini to 32M.

    To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

    ini_set('memory_limit', 32 * 1024 * 1024);
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Seems I just upped it recently.

      What was also notable was the my "MySQL Packet Size " is 1,023.0 KB and the error message says (tried to allocate 1024 bytes).

      Can one just alter the MySQL Packet Size?

      Comment


      • #4
        The error is not related to the MySQL Packet Size.
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API

        Comment


        • #5
          our host will need to increase this value in the my.cnf file (or my.ini for Windows servers.)

          [mysqld]
          set-variable = max_allowed_packet=32M
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I'm having this problem on my fresh installation of vb4 as well. I've implemented the suggestion of edtiing the config.php file in #2 as I can do this without asking my host to do things (the other suggestion in #2 to edit php.ini).

            However, I note that you say that this is "temporary". In what way is it temporary and can I get by by just doing this without asking my host to do anything?

            Thanks!

            Originally posted by Steve Machol View Post
            Your PHP does not have enough memory allocated to it to complete this operation. Ask your host to increase the 'memory_limit' varible in php.ini to 32M.

            To temporarily up your limits edit your includes/config.php file and add these lines right under the <?php line:

            ini_set('memory_limit', 32 * 1024 * 1024);

            Comment


            • #7
              Hello All,

              there are 20608 records in my forum table .................after update the counter I start getting following error every time I click on the forum url

              Fatal error: Out of memory (allocated 43778048) (tried to allocate 256 bytes) in /home/wsfcom/public_html/discuss/vbseo/includes/functions_vbseo_vb.php on line 1016

              I tried to increase the memory limit upto 2g but still getting the same error

              Please help

              Comment


              • #8
                If you're still getting the error after upping the memory, you should speak to your host
                Vote for:

                - *Admin Settable Paid Subscription Reminder Timeframe*
                -
                *PM - Add ability to reply to originator only*
                - Add Admin ability to auto-subscribe users to specific channel(s)
                - "Quick Route" Interface...

                Comment


                • #9
                  What this code suppose to do?! I get 30seconds exceeded limit on this line! some one told me to disable "related topic" and i did it but no success.

                  Comment


                  • #10
                    What code? The error in post #6 is from vBSEO.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      No, First Post:
                      forum/includes/functions_search.php on line 219
                      Also i am on vb3.8 and i think first poster was on it too.

                      tnx for reply

                      Comment


                      • #12
                        Then post #2 is still applicable.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Then post #2 is still applicable.
                          Yea but i want to know what this line do?! I mean is there a way to disable it?! Because my problem is not memory. It is 30Sec execute time limit error.

                          Comment


                          • #14
                            Sorry, I don't understand what your confusion is. Please start your own thread with all the relevant details. Thank you.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X