Announcement

Collapse
No announcement yet.

User xxxx has already more than 'max_user_connections' active connections

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • User xxxx has already more than 'max_user_connections' active connections

    Hello,
    I am having very frequently this error. And i would like to know how to troubleshoot it :

    mysql_connect() [<a href='function.mysql-connect'>function.mysql-connect</a>]: User xxxx has already more than 'max_user_connections' active connections
    /xxxx/xxxx/www/forum/includes/class_core.php on line 273

  • #2
    You can ask your host to increase the value for max_user_connections

    Comment


    • #3
      I was using SMF before and had never received this error. And this parameter was the same in the host side.

      Is there any parameter in vB Admin CP to say to close MySQL Connections ?

      Comment


      • #4
        Make sure your config.php has "use persistent connection" set to 0.

        Comment


        • #5
          I woke up to 50 or so of the same message and will be interested to see responses to your question.

          Thanks,
          Mia
          http://MainStreetMom.com
          Mia
          http://MainStreetMom.com

          Comment


          • #6
            Originally posted by Floris View Post
            Make sure your config.php has "use persistent connection" set to 0.
            I have already this settings in my config.php file :

            PHP Code:
            $config['MasterServer']['usepconnect'] = 0

            Comment


            • #7
              Then as Floris said you will need to ask your host to increase the value for max_user_connections.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by Steve Machol View Post
                Then as Floris said you will need to ask your host to increase the value for max_user_connections.
                Have asked the host to increase this parameter. But they say this parameter is already set to 10 and do not plan to increase it and suggest to look into the scripts .

                Anyway, i am having this error almost 5 or 6 times per day.

                Comment


                • #9
                  10 is a ridiculously small number. It's not a script problem, your forums are simply too 'busy' for the measly amount of MySQL connections your host allows you to have. Them blaming the script is preposterous!

                  Who is your host? I need to add them to a list of hosts to avoid.

                  Meanwhile your only real option given your host's attitude is to find a more suitable host. Good luck.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Originally posted by Soninkara View Post
                    Have asked the host to increase this parameter. But they say this parameter is already set to 10 and do not plan to increase it and suggest to look into the scripts .

                    Anyway, i am having this error almost 5 or 6 times per day.
                    Wow, you could easily hit ten just from one search engine crawling the site since they like to open multiple simultaneous connections; ten is absurdly low.

                    Comment


                    • #11
                      Usually this number is 100 or some providers even allow 500 if you're lucky. In most cases when I emailed them to please increase the value from 100 to 250 or 500 it was not a problem.

                      Comment


                      • #12
                        I am having this problem as well. I have been in communication with my web host, and even though my site is fairly small (230 users) and the bandwidth usage now that we're on vB is lower than when we used SMF, we're having tons of problems with the maximum connections. My host has the setting at 25 and is refusing to raise it.

                        Comment


                        • #13
                          25 is too small. Your only option is to either live with this, or find a more suitable host.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            On my current webhost I've got max_user_connections 0. Does this just mean the max user has been disabled and there is no max? Btw, I got this number by checking admin cp -> maintenance -> diagnostics -> system information.

                            I'm thinking of changing servers but it's hard to find a "cheap" and good webhosting company (one that is honoust). One told me their number of connections is 500 and max_user_connections is set to 50. What does this exactly mean? Most of the times there are 20-50 users online but there are times that I've got over 100 users online. With a max_user_connections limit set to 50, what can I expect in the case of 100 users coming online?

                            Comment


                            • #15
                              hi, I have the same problem in new server (dedicated), I asked to the host and he replied
                              Code:
                               Edit the /etc/my.cnf file and change the following three lines:
                              interactive_timeout=10
                              wait_timeout=10
                              connect_timeout=10
                              
                              to the following:
                              
                              set-variable = interactive_timeout=10
                              set-variable = wait_timeout=10
                              set-variable = connect_timeout=10
                              Restart mysql and you should be ok.
                              
                              If you need us to do this just let us know what value you need.
                              I have no idea about value I need
                              Any suggestion? (forum has 200/300 users online)
                              Be my guest in my B&B in sicily, on the sea

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X