Announcement

Collapse
No announcement yet.

NIX Server Load Limit Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NIX Server Load Limit Problem

    The NIX Server Load Limit setting has no effect on my server. I open a top window to monitor the load then set the load limit for 1/2 of what the current server load is, save the settings, reload the browser with the forum, and it doesn't give me "come back later" message, it just doesn't have any affect.

    I disabled the plug in and hook system and just run VB native code, still didn't work.

    My system:
    VB 3.6.4
    dedicated server P4 2.8 with 1.5GB RAM
    RHE Linux
    PHP 4.4.4
    Mysql 4.0.27-standard

    Any ideas?
    Last edited by treasureman; Thu 1 Feb '07, 1:52pm. Reason: clarity

  • #2
    Administrators do not receive the server too busy message. You will need to be either a guest or logged in as a registered user to receive this.
    Kerry-Anne :)

    Twitter Blog

    www.peterska2.com www.worldnewszone.com www.popularusenetgroups.com www.superclickers.co.uk www.forumsforchrist.com www.browsergameplanet.com

    Comment


    • #3
      I logged out and didn't see it as a guest, and also logged in as a test user (non admin) and did not see it.

      Comment


      • #4
        I'm sure I've seen this mechanism work on my server.

        What's the first number of the system load indication on the homepage of the admincp? And what did you set the *NIX Server Load Limit to?
        "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
        - Edsger Dijkstra

        Comment


        • #5
          Originally posted by renep View Post
          I'm sure I've seen this mechanism work on my server.

          What's the first number of the system load indication on the homepage of the admincp? And what did you set the *NIX Server Load Limit to?
          First number currently is 2.19. Of course it varies

          I set the load limit to 1.00 for testing purposes when the load was over 2

          I wouldn't leave it to 1.00 if I could get it to work I would put it about 4.00 or 5.00

          Again, I opened a SSH session and had "top" running in a window so I could monitor the load. Then I changed the limit in the admin CP to 1.00. When the load was over 2.00 in "top", I logged out and view the forum as a guest. Nothing happened, I wasn't turned away. Also I logged in as a "test user" and was not turned away. All the while viewing the "top" window load settings at over 2.00.

          I really would like to get this to work.

          PS - I also disabled plug in system and ran only VB code to make sure that wasn't the problem.

          Comment


          • #6
            Anyone else have any ideas?

            It seems that others have this problem also because the "similiar threads" feature pulled up several with the same problem.

            Comment


            • #7
              Steve can you or someone else answer the original problem I posted? I see that others had the same issue but a search did not turn up a solution.

              Comment


              • #8
                If the server load setting and limit is not working for non-Admins, then this means your server does not allow access to this function.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Originally posted by Steve Machol View Post
                  If the server load setting and limit is not working for non-Admins, then this means your server does not allow access to this function.
                  Is there any fix or work around to this?

                  It is my own dedicated server and I can make changes, just need to know which ones to make.

                  Comment


                  • #10
                    Fix for what exactly?
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Originally posted by treasureman View Post
                      It is my own dedicated server and I can make changes, just need to know which ones to make.
                      I think vB (which is running with the effective user id of Apache) needs access to /proc/loadavg.

                      This is the code in global.php:

                      Code:
                      if ($vbulletin->options['loadlimit'] > 0 AND PHP_OS == 'Linux' AND @file_exists('/proc/loadavg') AND $filestuff = @file_get_co
                      ntents('/proc/loadavg'))
                      "The lurking suspicion that something could be simplified is the world's richest source of rewarding challenges"
                      - Edsger Dijkstra

                      Comment


                      • #12
                        /proc/loadavg exists on my server, I don't know why the script isn't reading it.

                        Any ideas? Permissions are 444, it should be able to read it.

                        Comment


                        • #13
                          Okay, problem solved, this should be put into the FAQ because I saw other posts with others having this problem.

                          Vbulletin must be able to read the file /proc/loadavg

                          If it can not make sure that /proc/loadavg is added to your php_admin_value open_basedir setting in the httpd.conf file for the virtual host file that your forum is located on.

                          That solved the problem for me, YMMV.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X