Announcement

Collapse
No announcement yet.

PHP Error: Cannot Create References...nor Overloaded Objects

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP Error: Cannot Create References...nor Overloaded Objects

    Fatal error: Cannot create references to/from string offsets nor overloaded objects in includes\class_core.php on line 1283
    I just recently got this error. I upgraded to 3.6.4 about 2-3 days ago and the error started appearing last night. I found this thread which offered steps to remedy the problem:

    To fix the error, run this query:

    UPDATE datastore SET data = '' WHERE title = 'options';

    Then, upload the tools.php file from the do_not_upload folder of your vBulletin zip file, and use that to rebuild the options.
    That works temporarily, but a little while later - the error comes back. Somebody help me out here please.

    PS. Before anyone asks -- I've already tried disabling all Plugins and Hooks, but the error still shows.

  • #2
    Run 'Suspect File Version' in Diagnostics and report back the results.

    Admin CP -> Maintenance -> Diagnostics -> Suspect File Versions

    Do any show as 'File does not contain expected contents', version mismatch or missing? If so, you need to reupload the original vB non-image files. Make sure you upload these in ASCII format and overwrite the ones on the server.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Two files showed "File does not contain expected contents": index.php and online.php -- I replaced both with fresh ones; the error came up back an hour or so afterwards.

      Comment


      • #4
        After an hour or so? Are you absolutely sure you have disabled all plugins globally via config.php?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Yep, I checked after I noticed the error message again, plugins are disabled.

          Comment


          • #6
            Which versions of PHP and MySQL are you running?

            Also since that line of code is related to templates versions, do you have any custom templates and have you tried reverting them?
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              PHP: 4.4.2
              mySQL: 4.1.18-nt

              We're using a Custom Template created for 3.6.4 -- should I try using the Default Template and see if the error goes away?

              Comment


              • #8
                Those versions are fine. Try this. Create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem?
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Nope, the error still returned.

                  Comment


                  • #10
                    Hmmm...I really don't see how this is possible with the default vB code and templates.

                    If you really have done everything we've recommended and are running no add-ons or modifications, fill out a support ticket at:

                    http://members.vbulletin.com/members...ontactform.php

                    Please include a complete description of the problem and be sure to include the login info to your Admin CP, phpMyAdmin and FTP in the 'Sensitive Data' field.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      I saw in some of the other threads that users' hosts had APC running and that if it was disabled, all was fine; what is APC and could this be our problem?

                      The server we're on is messed up ATM and even I can't access Plesk -- but I'll fill out a ticket as soon as it's back up.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X