Announcement

Collapse
No announcement yet.

Instantiation of vB_Postbit Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • George L
    replied
    Originally posted by Gabrielt View Post
    After upgrading 3.6.9 to 3.6.10 this error message started to show up here. After reading this thread and learning this was caused by Xcache I simply restarted Apache with apachectl restart and our forums came back to life.

    Cheers,
    Gabriel.
    yeah sometimes only way to clear old xcache entries is with a proper restart of apache instead of via xcache admin page.

    Leave a comment:


  • Gabrielt
    replied
    After upgrading 3.6.9 to 3.6.10 this error message started to show up here. After reading this thread and learning this was caused by Xcache I simply restarted Apache with apachectl restart and our forums came back to life.

    Cheers,
    Gabriel.

    Leave a comment:


  • CrystalStarLight
    replied
    Hi! I just starting getting this after moving over to a shared server. It happens only in my forum when someone tries to view a thread.

    I don't know what Xcache is or how to remove it. Can someone let me know?

    Also am I supposed to clear it or remove it? They can mean different things.

    Thank you!

    Last edited by CrystalStarLight; Fri 9th Nov '07, 4:18pm.

    Leave a comment:


  • George L
    replied
    you do it in xcache admin page

    Leave a comment:


  • jeffinj
    replied
    Originally posted by eva2000 View Post
    the above error is fixed if you either clear xcache cache and/or recompile PHP
    How do you do this in DirectAdmin?

    Leave a comment:


  • George L
    replied
    the above error is fixed if you either clear xcache cache and/or recompile PHP

    Leave a comment:


  • phpxcache
    replied
    can someone try http://xcache.lighttpd.net/pub/snapshots/ 1.2-dev-r430 please? i can hardly reproduce it

    Leave a comment:


  • dinodonk
    replied
    you should clear all cache....

    Leave a comment:


  • Spinball
    replied
    I was also getting the error after upgrading to Xcache. But on only 1 of our 2 forums. It was running at 3.6.4.

    Leave a comment:


  • vissa
    replied
    I'm on vb 3.6.4 (patched w 365 security) xcache 1.03, php 4.4.5 and I am having users very rarely report this error as well.

    Fatal error: Direct instantiation of vB_Postbit class prohibited. Use the vB_Postbit_Factory class. in /includes/class_postbit.php on line 239

    Hopefully something that xcache can fix. Do people have these types of problems with APC? I also had to disable xcache for a moodle site. Does xcache 1.2 have less bugs?

    -vissa

    Leave a comment:


  • Zia
    replied
    right now we are on vb3.6.4 & using Xcache 1.2.0 the last stable version..
    installed from the source & it working fine....w/o any problem...much faster than eAcc.

    Leave a comment:


  • George L
    replied
    could be problems with the rpm binary used for your setup ? tried source install for Xcache ? or with vB 3.6.x ?

    no probs here with Xcache 1.03 compiled from source for CentOS 4.x server with vB 3.5.x and vB 3.0.x forums with PHP 4.4.4 and MySQL 4.0.27

    what did your apache error log have regarding Xcache related errors if any ?
    Last edited by George L; Sat 27th Jan '07, 3:52pm.

    Leave a comment:


  • Indy
    replied
    Steve is correct. The problem that I stated in the opening post of this thread is now gone. I edited my php.ini file to remove everything concerning xcache and then restarted HTTP Server (Apache).

    Leave a comment:


  • Steve Machol
    replied
    We have confirmed this is a problem with XCache. Not much more I can add to this. Here is one report that I can share:

    http://forum.lighttpd.net/topic/3854

    Leave a comment:


  • Mike Warner
    replied
    I get this error in the admin CP when I go to vBulletin Option > Search Type.
    Code:
    Fatal error: Direct Instantiation of vB_Database_Alter class prohibited. in /includes/class_dbalter.php on line 106
    Yes, I am running xcache, but so are many other people.

    Leave a comment:

Related Topics

Collapse

Working...
X