Announcement

Collapse
No announcement yet.

Google Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Google Errors

    Here is the text contained in "vBulletin (forum) Database error!" emails I've been receiving since upgrading to vB 3.6.4 from 2.2.9.

    Database error in vBulletin :
    Invalid SQL: SELECT avatardata,dateline,filename FROM customavatar WHERE userid=245 mysql error: Unknown column 'avatardata' in 'field list'
    mysql error number: 1054
    Date: Sunday 14th of January 2007 09:54:07 PM
    Script: /forums/avatar.php?userid=245&dateline=1046185560
    Referer:
    http://64.233.167.104/search?q=cache...&ct=clnk&cd=27
    I've received about 20 of them and the link contained in the email points to a thread from my old installation, not my new one. I've attached a screenshot of what the link brings up. What does this mean and what should I do about it? Thanks.

    Jake Crause
    www.homebuiltairplanes.com
    Attached Files
    Jake Crause
    www.homebuiltairplanes.com

  • #2
    Are you still receiving those, perhaps they were generated while you were upgrading.

    newer versions of vbulletin include the vb version in the error msg.

    Comment


    • #3
      Yep, I just received the errors last night. I upgraded two days ago.

      One thing I did not mention is that when I upgraded, I upgraded using a copy of the database with a different database name to fix any bugs prior to going live. Then, after fixing all the settings, I transfered the new directory to the base directory but left the database name the same so that I didn't have to change the config settings. Could this be part of the problem? Thanks.

      Jake
      Jake Crause
      www.homebuiltairplanes.com

      Comment


      • #4
        And actually I just realized that every time I view the link in the email I get the same number of database error emails as there are avatars on the page the link points to.
        Jake Crause
        www.homebuiltairplanes.com

        Comment


        • #5
          Make sure no old files are left over ..

          AdminCP > Maintenance > diagnostics > file suspect version

          Comment


          • #6
            Here are the files listed when running the suspect version command:

            in the ./
            avatar.php
            buddy.php
            cp.css
            links.php (I originally had the Links Directory hack installed before the upgrade.
            member2.php
            private2.php
            rules.php
            sendtofriend.php
            vbcode.js
            vbcode.language.js

            in the ./install
            upgrade.php (it says file not found, which is a good thing I believe)
            Jake Crause
            www.homebuiltairplanes.com

            Comment


            • #7
              If 3.6.4 does not have avatar.php or the other files, and you dont' want to use those addons anymore, remove them. Then old search results will get a 404 and won't generate an error.

              Comment


              • #8
                Ok, I'll give it a try. Thanks for the help.
                Jake Crause
                www.homebuiltairplanes.com

                Comment


                • #9
                  No problem, hopefully it gets resolved.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X