Announcement

Collapse
No announcement yet.

image verification

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • image verification

    My image verification is not working.

    Do i need to install anything on the server to get this to work.

    The server is running Cpanel,

    I have tried to install imagemagick and its says done yet it is still not working.

    What is GD do i need to install that as well?

    Under VB options, image settings,
    It is asking for a path for imagemagick as unix usr/local/bin/ would that be typical for all servers?
    Under maintenance and PHP into it says PHP4.4.4, should their be a reference in that file to GD support or Imagemagick.

    waiting in anticipation.
    Last edited by CTC; Sat 13 Jan '07, 7:37pm. Reason: updated info

  • #2
    For GD, PHP must be compiled with full GD support.

    For ImageMagick your host will need to install IM version 6 or higher on this server then you will need to specify the correect path to it in the Image Settings.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Image Verification

      Thanks Steve,

      I had to recompile on Cpanel under WHM, and tick the option for GD support.

      I also had to install the image magick from the command line.

      To test on cpanel whether it was working or not i performed the following

      http://www.mydomainname.com/forum/image.php?i=gd


      http://www.mydomainname.com//forum/image.php?i=im

      They both returned errors.

      Next step was to perform this in the command prompt in linux.

      # wget ftp://ftp.imagemagick.org/pub/ImageM...eMagick.tar.gz
      # gunzip -c ImageMagick.tar.gz | tar xvf -
      # cd ImageMagick-6.3.1
      # ./configure
      # make
      # make install
      # cd PerlMagick
      # perl Makefile.PL
      # make
      # make install

      And walla it was installed.

      Went back into vbulletin and under the options for image settings, i flagged imagemagick and then set the defualt path and low and behold was it shown.

      I hope this information helps other users as it took me a good 4 hours to resolve.

      Comment


      • #4
        It would help if you provided the real URL and enabled phpinfo.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X