Announcement

Collapse
No announcement yet.

Rebuild Post Cache Database Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rebuild Post Cache Database Error

    My forum has a little over 1,000,000 posts.

    I tried to rebuild the post cache today with varying values (1,000 posts at a time, 5,000, 10,000, 50,000).

    Upon each attempt, the rebuilding quits with a database error:

    Code:
    Database error in vBulletin 3.6.4:
    
    Invalid SQL:
    
                REPLACE INTO postparsed
                (postid, dateline, hasimages, pagetext_html , styleid, languageid)
                VALUES
    
    *SNIP SNIP SNIP SNIP SNIP Millions of lines of code.*
    
    
    MySQL Error  : Got a packet bigger than 'max_allowed_packet' bytes
    Error Number : 1153
    Date         : Sunday, January 7th 2007 @ 10:14:40 PM
    Script       : http://www.zefron.com/forum/admincp/misc.php?do=buildpostcache&startat=379001&pp=1000
    Referrer     : http://www.zefron.com/forum/admincp/misc.php?do=buildpostcache&startat=378001&pp=1000
    IP Address   : 68.***.**.***
    Username     : Bruce
    Classname    : vb_database
    What am I doing wrong?

    Thanks,
    Bruce

  • #2
    Addition - I've noticed that the database error always occurs around the same post ( Processing: 39998 1 or Processing: 39999 1).

    These two posts are not massive by any means. One contains only a sentence or two, while the other contains a few hundred lines.

    Any ideas?

    Comment


    • #3
      You or your host will need to increase the 'max_allowed_packet' in my.cnf, then restart MySQL. I recommend 16M and if that doesn't work try 32M.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I've increased to 32MB, and I'm still getting errors (this time toward post 379999).

        Comment


        • #5
          If you are getting the exact same error then you will need to increase this until you no longer get that error.

          Make sure restart MySQL after making the change.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            I've set the value all the way up to 500MB (and have made sure to restart MySQL after each change), and I still get the error mentioned in the first post.

            This time, the stop occurred at Processing: 379999 1.

            Could this issue be of a potentially larger scope?

            Thanks,
            Bruce

            Comment


            • #7
              Are you getting the same error?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                yeah, I've gotten the same error, and gotten a variety of excuses from Support here when asking about it over the past 6 months....
                don't get me wrong, i love VB, and love what I've been able to add to it, but I'm really tired of the company line on stuff "Its not our app", "We can't help you...check vb.org", etc

                Comment


                • #9
                  Theres not normally a need to directly rebuild the post-cache, the easiest way is to let it natural rebuild itself over time, empty the postparsed table and let it rebuild.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X