Announcement

Collapse
No announcement yet.

Invalid File Error while uploading avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    The only thing I see that could cause this is that your 'upload_tmp_dir' setting is empty. You (as root) or your host will need to edit php.ini and set 'upload_tmp_dir' to point to the full path to a directory on the server that is chmod'd to 777.

    You will also need to restart Apache after making this change.

    Leave a comment:


  • JGNYC
    replied
    Originally posted by Zachery View Post
    Do you allow animated avatars for your users?
    Yes, and it doesn't work for regular image files too.

    Leave a comment:


  • Zachery
    replied
    Do you allow animated avatars for your users?

    Leave a comment:


  • JGNYC
    replied
    Attached
    Attached Files

    Leave a comment:


  • Zachery
    replied
    WHat sort of file are you trying to upload, can you attach it here?

    Leave a comment:


  • JGNYC
    replied
    I set the safemode upload to No in Server Settings and Optimization Options and I'm still getting the error.

    Leave a comment:


  • Zachery
    replied
    Turn off the Upload in Safemode option and try again.

    Leave a comment:


  • JGNYC
    replied
    Originally posted by Paul M View Post
    What happens if you run the upload diagnostics test (in ACP > Maintenance > Diagnostics)
    Pertinent PHP Settings file_uploads:On
    open_basedir:None
    safe_mode:Off
    upload_tmp_dir:None
    upload_max_filesize:7.00 MB

    Results No errors occurred while opening the uploaded file for reading. You should be able to turn off the "Upload In Safe Mode?" option without any adverse effects.

    Leave a comment:


  • Paul M
    replied
    What happens if you run the upload diagnostics test (in ACP > Maintenance > Diagnostics)

    Leave a comment:


  • JGNYC
    started a topic Invalid File Error while uploading avatars

    Invalid File Error while uploading avatars

    Users cannot upload avatars. When they try, they receive the error "Invalid file"
    I'm running 3.6.4
    It appears that my webhost has safe mode set to off.

    Any ideas?
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X